Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,234
Community Members
 
Community Events
176
Community Groups

Custom fields disappearing from issue during create forcing me to re-add them.

Edited

I consider myself a very seasoned admin having worked with Jira for over 8 years. I've started to run into an issue recently that has me baffled. When creating a new issue, the custom fields I added to the screen, which were showing up find started disappearing requiring that I re-add them while on the issue screen. Adding to my confusion is that after adding the fields, when I try to create a new issue of the same type, I have to readd the fields all over again. When I edit the issue, all the fields are displayed. The evidence seems to point to something special about the create flow and permissions??

1 answer

1 accepted

0 votes
Answer accepted
Tom Lister Community Leader Dec 04, 2022

Hi @Dennis Arndt 

Have you got some screenshots/specific examples?

I don't know of any settings that can be made on the create flow/permissions step that would affect the permission at the field level.

Other than your screen scheme is set to use a different screen definition for create than is used for edit and view.

Also check whether your layout setting are having some effect

https://support.atlassian.com/jira-software-cloud/docs/configure-field-layout-in-the-issue-view/

Jira Fields Not Showing.png

 

I've checked the boxes for each of the unselected fields, and they show up for a while (maybe while the session is still active?) but after some event I they are unchecked?

As I stated, this appears to only be an issue during the Creation of an issue.

Thanks in advance for your help.

Tom Lister Community Leader Dec 05, 2022

HI @Dennis Arndt 

Could you try changing the 'Custom fields' drop down to 'All fields' setting?

That is the default and should show all the fields you have placed on the create issue screen.

The custom fields option is to allow users to set their own reduced list of shown fields if they choose.

Hi @Tom Lister 

I tried that and it appears to have worked. Not sure how the other option was "set"?  The reason I went to it in the first place was because the fields were not showing up on the Create issue page but were showing up on all other actions. 

Thanks for the help. I would suggest you can mark this as SOLVED

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS

Atlassian Community Events