Custom field in email shows in 1 line when using HTML

Hi,

When using HTML email notification the custom filed that I added shows in 1 line, for example:

1. oren
2. test

Will be shown has:

1.oren 2.test

How can I fix it?

I'm using this to show the text:

$issue.getCustomFieldValue("customfield_13188")

Thanks,

Oren.

2 answers

1 accepted

0 vote
Renjith Pillai Community Champion Jan 27, 2013

Just try the following (I have not tried it myself):

$textUtils.htmlEncode($issue.getCustomFieldValue("customfield_13188"))

And may be use $textUtils.hyperlink as well

Thanks but didn't work still the same,

When looking at the code of the email I receive it looks like:

<br>

oren

katz

asdf

<br>

But it will shows as "oren katz asdf" because there's no <BR> after each word.

It's driving my crazy :)

Renjith Pillai Community Champion Feb 02, 2013

$issue.getCustomFieldValue().replaceAll("\n","<br/>")

I am guessing that the free text field has \n for newlines.

$issue.getCustomFieldValue("customfield_13188").replaceAll("\n","<br />") works!!!

Thank you very much! and thank you Matthew as well!

Oren.

you've marked your question as being an OnDemand query but that is a restricted function in OnDemand?

http://confluence.atlassian.com/display/AOD/Restricted+Functions+in+Atlassian+OnDemand#RestrictedFunctionsinAtlassianOnDemand-JIRA

The procedure for customising email content sent in notification messages requires editing Velocity files within the JIRA webapp. This makes it a special case of "customising source files". See JST-1791 and JRA-7266 for feature requests to allow customisation of email contents through the web UI.

Email will do one line for field, that is their expected behaviour.

where are you using $issue.getCustomFieldValue("customfield_13188")?

Sorry I ment On Premise - installed on my server.

I'm editing issuecreated.vm under classes/templates/email/html

You can see in the pic I've added "Root Cause" but it should be:

"
Root Cause: dsad
fgghhg
123
oren
"

and not:

"Root Cause: dsad fgghhg 123 oren"

Just like "Description"

This is untested but it's cut & paste from something similar, try it with caution & you will have to debug it

#if ($issue.getCustomFieldValue("customfield_13188"))
        #set ($optionList = $issue.getCustomFieldValue("customfield_13188"))
       &lt;table border="0" cellpadding="0" cellspacing="0" style="padding:0;text-align:left;width:100%;" width="100%"&gt;
        #foreach ($val in $optionList)
            &lt;tr&gt;&lt;td&gt;$val&lt;/td&gt;&lt;/tr&gt;
        #end
       &lt;/table&gt;
#end

I'm assuming your CF is returning a List object, if it's not then this won't work.

Thanks but is doesn't show anything

what's the type of your custom field?

Free Text Field (unlimited text)

Well that explains why mine would not work, I assumed you were using a multi select as you data looked like a structured list.... back to the drawing board. #mustnotmakeassumptions

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,327 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot