Could not transition issue through workflow using workflow buttons - getting generic error message

Could not transition issue through workflow using workflow buttons - We recently faced an issue where we were unable to transition some of our tickets through workflow by clicking the workflow buttons in the ticket. The ticket type was ZS Change Request. The tickets were noticed this in were:

0116IL2653-30

0116IL2653-22

0116IL2653-12

We were able to see the buttons to move to the next step, and clicked then were brought to the appropriate screen, but when we again clicked the button in the screen we got a Red Error box at the top with no error message. This made it impossible to figure out why it was not working. Also, it did not happen for all tickets, just these 3 in particular (and possibly others that we did not identify yet).

In each case, we were able to transition through workflow by using a bulk change and choosing transition.

We have confirmed that this is not an access / permission issue. Please advise. Thank you!

2 answers

1 accepted

Accepted Answer
0 votes

This problem has been solved by Atlassian Support team upon following the instructions on the following knowledge base article:

https://confluence.atlassian.com/display/JIRAKB/Edit+or+Update+Issue+results+in+a+NullPointerException

Cheers!

0 votes

If you're getting a red box and no error message, then you probably want to read the application log to see what the (hidden) error is.

(I'm also a bit confused on those ticket numbers - they don't look like Jira references)

We changed the requirements for the project key to allow numbers, which is one of our requirements. How can I read the application log? I don't have access to the server.

I'm afraid you're probably a bit stuck if you don't have access to the server - you need to ask your server owners to get you the log file because you almost certainly need to see it to debug this problem.

You could try raising a support request from within Jira - that will read some of the log file information as it logs it with Atlassian.

Your change of key could actually be the problem too - I know there are problems in Greenhopper if you allow numeric keys in some versions. More to the point, I know that starting a project key with a number causes some issues in common plugins and in some of the core functions in Jira as well - that's why I asked - from long bitter experience, I know never to start a project key with anything other than a letter (although everything I've worked with has been fine with numbers elsewhere)

If you need to log this with Atlassian, you could well be asked to move the issues to a project that has a standard key pattern before they can help you.

I cannot change the project key requirements and actually consulted with an Atlassian partner on this change. The thing thats odd is that we have hundreds of tickets across 80+ projects using this same key structure and have not ran into this issue. I can't find anything different about these 3 tickets. I have already raised a support ticket, so hopefully someone will be able to help. Thanks for your thoughts!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

27,295 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you