Could not find a field-type definition with name "h2" in atlassian

 

3 answers

The reason this is happening is because the latest JIRA data version is not compatible with the version of JIRA you are using.

To fix this, specify the following as an argument to your run command:

--data-version PRODUCT_VERSION

where PRODUCT_VERSION matches the version of JIRA you're trying to start.

I am facing the same error. I downloaded few sample connect plugins and after having all the dependencies using npm I ran atlas-run-standalone --container tomcat7x --product jira --version 7.1.0-OD-03-049 --data-version 7.1.0-OD-03-049 --bundled-plugins com.atlassian.bundles:json-schema-validator-atlassian-bundle:1.0.4,com.atlassian.upm:atlassian-universal-plugin-manager-plugin:2.20.1-D20150924T170115,com.atlassian.jwt:jwt-plugin:1.5.4,com.atlassian.plugins:atlassian-connect-plugin:1.1.66 --jvmargs -Datlassian.upm.on.demand=true but getting the same error.

Have you checked the version of Java vs version of JIRA? That's the most common cause.

Hi Nic, java -version java version "1.8.0_65" Java(TM) SE Runtime Environment (build 1.8.0_65-b17) Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode) atlas-version ATLAS Version: 6.2.2 ATLAS Home: /usr/share/atlassian-plugin-sdk-6.2.2 ATLAS Scripts: /usr/share/atlassian-plugin-sdk-6.2.2/bin ATLAS Maven Home: /usr/share/atlassian-plugin-sdk-6.2.2/apache-maven-3.2.1 AMPS Version: 6.2.1 -------- Executing: /usr/share/atlassian-plugin-sdk-6.2.2/apache-maven-3.2.1/bin/mvn --version -gs /usr/share/atlassian-plugin-sdk-6.2.2/apache-maven-3.2.1/conf/settings.xml Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256M; support was removed in 8.0 Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9; 2014-02-14T23:07:52+05:30) Maven home: /usr/share/atlassian-plugin-sdk-6.2.2/apache-maven-3.2.1 Java version: 1.8.0_65, vendor: Oracle Corporation Java home: /usr/java/jdk1.8.0_65/jre Default locale: en_IN, platform encoding: UTF-8 OS name: "linux", version: "4.2.0-22-generic", arch: "amd64", family: "unix"

Can you give more information? Are you admin? What would you do?

Where is the error occurring and what are you trying to do when it happens?

I got this fixed by using the --data-version PRODUCT_VERSION AND using the product version from the pom.xml. So the version is in three places (in the pom.xml, as parameter to "-v" and as parameter to "--data-version").

 

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,864 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot