Connecting to Jira gives blank webpage with address errors.jsp

When I try to connect to JIRA I am redirected to a page that only has the url http:localhost:8080/secure/errors.jsp and no other information.

Looking at the JIRA logs that is the last entry:

http-nio-8080-exec-2 warn ipaddress anonymous 856x2x1 /secure/errors.jsp Rejecting security-senstive request that bypassed Johnson filter

 

If i run shutdown.sh and startup.sh I can connect but the error returns after a server reboot.

 

Thank you for any assistance.

1 answer

Hey Ryan!  

When you're doing a full server reboot, are you shutting down JIRA using shutdown.sh/startup.sh prior?  Or just performing a shutdown -r now?

My first thought is that, if you are, the tomcat and/or the plugin cache is getting corrupt somehow, and throwing that error on the subsequent startup.  

To remove the plugin cache:

  1.  Stop JIRA
  2. Delete the following folders:
    • JIRA_HOME/plugins/.bundled-plugins
    • JIRA_HOME/plugins/.osgi-plugins
  3. Start JIRA

To remove the tomcat cache:

  1. Stop JIRA
  2. Access your JIRA installation directory, then the Work directory. Delete the contents of the folder. DO NOT DELETE THE WORK FOLDER. Only delete the contents.

See if that helps.

If it doesn't, could we get more of the log to take a look at?

Thanks!

I have removed the tomcat cache in the past to get it up after a reboot.

I tried deleting those plugin folders and now I cannot get the server to come up at all. I get the error failed to delete felix file in .osgi-plugins. Looks like root took ownership when they were rebuilt. I did a chown jira:JIRA to the directory but still no joy. 

Just doing a sudo reboot.

 

Here are last 20 lines of JIRA log file.

 

at org.ofbiz.core.entity.GenericDAO.selectListIteratorByCondition(GenericDAO.java:831)
at org.ofbiz.core.entity.GenericDAO.selectByAnd(GenericDAO.java:730)
at org.ofbiz.core.entity.GenericHelperDAO.findByAnd(GenericHelperDAO.java:150)
at org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:903)
at org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:881)
at org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:850)
at com.opensymphony.module.propertyset.ofbiz.OFBizPropertySet.findPropertyEntry(OFBizPropertySet.java:298)
at com.opensymphony.module.propertyset.ofbiz.OFBizPropertySet.exists(OFBizPropertySet.java:170)
at com.atlassian.jira.propertyset.JiraCachingPropertySet.exists(JiraCachingPropertySet.java:566)
at com.atlassian.jira.propertyset.BootstrapOfBizPropertyEntryStore.getType(BootstrapOfBizPropertyEntryStore.java:67)
at com.atlassian.jira.propertyset.CachingOfBizPropertySet.exists(CachingOfBizPropertySet.java:139)
at com.atlassian.jira.config.properties.ApplicationPropertiesStore.getOption(ApplicationPropertiesStore.java:157)
at com.atlassian.jira.config.properties.ApplicationPropertiesImpl.getOption(ApplicationPropertiesImpl.java:85)
... 17 filtered
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Thread.java:745)
2016-08-03 16:42:00,756 http-nio-8282-exec-2 WARN anonymous 1002x2x1 - 192.168.200.102 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2016-08-03 16:42:07,386 http-nio-8282-exec-3 WARN anonymous 1002x3x1 - 192.168.200.102 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp

 

Hmmm.  What version of JIRA is this install?

I've never personally seen this before, but in researching a bit I did come across this issue:

https://jira.atlassian.com/browse/JRA-27438

Specifically there's a comment of someone who was having the same issue that you are after a full sudo reboot.  Looks like it was fixed in 7.0.2, so you might consider upgrading to at least that, (assuming you're on a previous version).

Thanks, this works for me.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,949 views 19 22
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you