Connecting JIRA to MS SQL issues

Hi,

My company is wanting to evaluate JIRA as a potential Issue/Bug Tracking tool, as well as to use it for our Agile development process, and Code Reviewing. We are trying to set up JIRA to connect to a MS SQL Express instance and have performed all the steps correctly for making the DB ready for JIRA and have verified that the user account created can access the newly created "jiradb". However, when we try to configure JIRA to connect to the DB with all the correct settings and click "Test Connection" we are always returned the Error of Connection refused... Any suggestions as to what the problem could be? The DB resides on the same machine as the JIRA install.

Ben

2 answers

1 accepted

0 votes
Accepted answer

The application log file should tell you more about the "connection refused" error. If you've ruled out the actual settings being incorrect as you copy them into Jira, then you need to start looking at ports and firewalls (yes, even for a local machine)

if you go into your configuration manager (for the database - I don't have the exact name in front of me). Verify that you have enabled TCPIP and that you have the port 1433 enabled. I am away from my database right now so I don't know exactly where it is set, but I know that there is a place for the ports, and in express they are disabled by default (at least they have been in the past).

I see that this is now answered, but I will put the following in here anyhow, just in case someone wants the steps sometime in the future.


Do you also have the option (start -> programs -> sql server -> Configuration tool -> Configuration Manager
Open that tool. Ensure that under SQL Server Services, that your server is running.
Everything else is just the default. You can close out of this window.

When you are logged into SQL Server Management Studio, click on "Security" (NOT security within the database, but the higher level option).
Click on Logins. You should see your user listed.
Right mouse click on the username and choose Properties.
Click on the "User Mapping" option on the left. Verify that for the database listed, the user is in the user role of DB_Owner.
Basically if this is true, then you probably have the user set up properly.
Right mouse click on it and choose properties. "Log on as", should have the "Built-in account" set to be Network service.
Expand "SQL Server Network Configuration" Ensure that "Protocols for JIRA" <where JIRA is the name of your service> have "TCP/IP" enabled.
Right mouse click on it, and choose properties, ensure that the IP Address is enabled, and the TCP port is set to 1433.
Also ensure that under the Protocol tab, that it is set to enabled.

Now expand the "Databases" tab, and expand your database. If you click on Tables, you will probably not see any of the JIRA tables created. If you do, then we are definitely heading down a rabbit trail right now?let me know.
Expand "Security" and users, right click on the username, select properities. You should be able to see that the user is in the DB Owner role. This is just a double check, because I always error on the side of caution.
Under the "Sucurables" make sure that that the user has full permissions. I usually go right into the explicit ones, and add in Grant for everything



Suggest an answer

Log in or Sign up to answer
Community showcase
Published Wednesday in Jira

Make your Atlassian Cloud products more secure: our NEW admin security guide

Hey admins! I’m Dave, Principal Product Manager here at Atlassian working on our cloud platform and security products. Cloud security is a moving target. As you adopt more products, employees consta...

91 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you