Configuring JIRA on Linux without a browser

I'm installing JIRA 5.2 on a Linux server, but cannot access the "localhost:8080" via a browser as the steps indicate. The server.xml file also indicates I can no longer configuring via this file, and should follow the GUI setup. What's my next step at this point?

4 answers

0 vote

Why do you say you cannot access from localhost:8080? Is it showing blank page? Did you install using installer?

while you installing jira what is the url you configured?

when you try to open the jira ,what is the error message/response you are getting?

The command line installer doesn't prompt for a URL. the instructions say that will be configured upon first accessing at the localhost address. But this isn't on my local machine, it's on a Linux server. JIRA is running per "ps aux | grep java", I'm just unable to access the GUI. Does that make sense?

localhost:8080 means "this machine, port 8080". It will only work on the machine you are running on.

It sounds like you've tried that address from your machine, rather than the server. If I'm right with that guess, then you need to change it slightly - try the raw IP address of the server instead - nip onto the server and run ipconfig, that should tell you something like 192.168.1.42, so try http://192.168.1.142:8080 and see what it does.

Hello Nic, using the raw IP address didn't work either. I didn't install using the installer, so I was never prompted to enter a URL. I thought older versions had this set in the server.xml file, however, that's doesn't appear to be an option in 6x.

Hi Charles,

Since you are probably installing JIRA on a Linux server that is not in your local network, you should be able to access JIRA using the IP address or if DNS has been assigned, using the domain name.

Make sure your linux firewall is setup correctly, usually only has port 22 open. You need to open port 8080 so that you can access JIRA.

vim /etc/sysconfig/iptables
 
# Firewall configuration written by system-config-firewall
# Manual customization of this file is not recommended.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 8080 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 8090 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 443 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-host-prohibited
-A FORWARD -j REJECT --reject-with icmp-host-prohibited
COMMIT

Hello Isaac, I've added the lines above with no success. I must be missing something else.

I presume I'll need to manually update the server.xml file to specify the URL as per older versions. - Nevermind, there is no place to do so in the file.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

763 views 2 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you