It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Comments in Jira are showing up twice / duplicate comments in Jira after Updating (double CSS?) Edited

After updating our Jira system from 7.9.2 to 7.12.1 we get a presentation error. All comments are showing up twice.

It seems that the second comment is without formatting and without newlines.

For better understanding here a screenshot

Screen Shot 2018-09-14 at 07.11.38.png

This happens to old comments (before the update) and new comments (after the update.

On the Icons above the comments, you see the trash can for deleting the comment. When I click on delete, both comments will be removed. So the comment is technically not duplicated rather than the comment is showing up twice.

Thanks a lot in advance for your help!

4 answers

2 accepted

3 votes
Answer accepted

Thanks @Keri for opening a support ticket for me. The support helps me with the problem and we solved it :)

I will provide the short solution here, for maybe other people who will have similar problems.

The causes for the problem can be attributed to a mechanism when a plugin or a dependency for a plugin fails to be initialized. Jira will mark this plugin as "Disabled" and will ignoring it next time when it starts up. 

To solve this here is the answer from Marko (Atlassian Support)

  1. Stop your Jira
  2. Delete everything from the pluginstate table:
    delete from pluginstate;

    Remember to back up the database before proceeding!

  3. Clear plugin cache by deleting $JIRA_HOME/plugins/.bundled-plugins and $JIRA_HOME/plugins/.osgi-plugins
  4. Delete content of $JIRA_INSTALL/work and $JIRA_INSTALL/temp directory (don't delete directories themselves)
  5. Start Jira. Now there are no weird artefacts in CSS, nor I can see duplicated comments

Thanks a lot for all the help :)

As written on the ticket, it seems some modules have been referred as disabled in the pluginstate table, needed for content rendering. In this particular example, we suspect the following were causing the problems:

com.atlassian.jira.plugins.jira-healthcheck-plugin
jira.filter.deletion.warning 
jira.feature.keys 
system.entity.property.conditions 

In regards as to why this would happen, whenever a plugin or a dependency for a plugin fails to be initialized, it will be marked as "Disabled", in this way, Jira will ignore it the next time it starts as it would normally have to wait for it to start, this is kind of a "defense" mechanism. As to why the plugin would fail to initiate it can be due to a timeout (taking too much time to start), plugin cache not refreshing correctly or or due to an actual error in the plugin start process. In any case, none of those possibilities are expected behavior and in case you continue experiencing issues of this kind of issues, it will indicate the need to investigate further. 

I got into the same issue and resolved this way.

1. Open Dev Tools
2. Go To Application tab
3. Clear Local Storage
4. Clear Session Storage
5. Clear Cookies
6. Clear Cache storage
7. Refresh the browser

Resolved my issue !!!!

seems to be a lot easier than log into the database and clear everything from the "pluginstate". I guess one of these "Clear ..."-commands will also clear this table "pluginstate".

Thanks for sharing!

Will everyone that has to view this page need to clear their cache? It seems going to the database would be easier.

While the process detailed in this accepted answer did not resolve the problem, it did hightlight the cause...

In my case, on a Windows 10 Home PC, I am seeing the duplicate comments and the Jira story details are not formatted.

But on a Windows 10 Pro PC, everything looks fine.

In both cases, Chrome is version 81.0.4044.129, and I'm accessing the same Jira story on our server which is Jira v8.4.1.

The difference is that the Developer Tools sidebar in Chrome for the Windows 10 Home PC shows 2 errors for the Jira story page, which say:

Refused to apply style from 'https://jira.mydomain.com/s/55d50f66765c3194b3bc5f8337419747-CDN/h04j5b/804002/cd2c316445a4bac2f0ac675717a915b0/1.0/_/download/batch/jira.webresources:global-static-adgs/jira.webresources:global-static-adgs.css' because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled.

It should be noted that the Windows 10 Pro PC is on the same network as the Jira server, but the Windows 10 Home PC is accessing the Jira story via the Internet. This means that a PING from the office PC to the Jira server is returning a private IP address, but pinging from my home PC is returning the public IP address.

Can this be resolved without resorting to making changes to the Jira server?

0 votes
Keri Atlassian Team Sep 17, 2018

Hey Henry,

 

Can you please tell us a little more about how you're adding the comments - is this through the UI or through email or another application?

 

Can you also show us the full screenshot of where this is happening and what tab you're viewing (if it's all activity or just the comments tab)?

 

Cheers, 
Keri

Yes of course. We did further investigations. It seems that we have both CSS files in our system. This one from 7.9.2 and the CSS from the new Jira version 7.12.1

Also, I tried to build up a fresh installation of Jira 7.12.1 and do a data migration with the .zip file I get from the Jira backup tool. But after doing the data migration with this zip file I have the same issue with the broken CSS (duplicated comments) than I have in my current instance.

Here you see the full screenshot of our duplicate comments, it´s only the presentation of the comments. Technical it´s one comment (that the reason why I put these red boxes around it)

duplicates-comments-broken-css-jira-fullscreen.png

 

Here you can see that we have three (?) CSS classes (.aui-header) for our header. Is this correct?

jira-double-css-classes.png

 

Also, we have several more CSS problems like these ones here:

projects-_broken-icons_Jira.pngUser_Profile_broken_Jira.png

 

Maybe it´s helpful here is the output of the chrome console from our default Jira Dashboard:

jira-console-output-1-2.pngjira-console-output-2-2.png

 

I hope this information helps.

I think we have now two possibilities to solve our issues.

  1. Repair somehow our instance?
  2. Find a solution to migrate to a new instance. But for this task, we must create a backup without the CSS? 

We never used a customized CSS in our instance. We have everything on default.

Keri Atlassian Team Sep 18, 2018

Hi Henry,

 

The CSS isn't held in your XML backup from Jira - it just holds a copy of the data in the database. 


What I'd suggest first, is trying Jira in Safe mode, I can see that you have a 500 error coming from the XPorter add-on so this should disable any third-party add-ons. 

 

The CSS files are included in the installer. You can try running the installer again to see if this resolves the issue. 

 

Cheers, 

Keri

Hi Keri,

thank's for clarifying what data are in the XML Backup from Jira.

I started the Safe Mode of Jira, all Plugins are disabled, except for:

Atlassian Troubleshooting and Support Tools
Atlassian Universal Plugin Manager Plugin
nothing changed. I also ran the installer again, this does not resolve the problem. Also, I recognize that there is an update for the jira-core (7.12.2). I installed it, and also this does not remove the problem.

I recognize that we are using a PostgreSQL database (engine PostgreSQL 9.3.20) with an older database driver: PostgreSQL 9.4.1212

 ___ Database Configuration _________________

         Loading entityengine.xml from                 : file:/opt/atlassian/jira/atlassian-jira/WEB-INF/classes/entityengine.xml
         Entity model field type name                  : postgres72
         Entity model schema name                      : public
         Database Version                              : PostgreSQL - 9.3.20
         Database Driver                               : PostgreSQL Native Driver - PostgreSQL 9.4.1212
         Database URL                                  : jdbc:postgresql://xxxxxxxxxxxxxxxxx.eu-central-1.rds.amazonaws.com:5432/xxxxxxxxx
         Database JDBC config                          : postgres72 jdbc:postgresql://xxxxxxxxxxxxxxxxxxxx.eu-central-1.rds.amazonaws.com:5432/xxxxxxx

Could this leads us to the errors we have?

Thanks a lot for your help!

Keri Atlassian Team Sep 19, 2018

Hey Henry, 

 

It looks like there may have been something wrong with your upgrade - your UI looks a little different than I would expect with Jira 7.12 (the drop down menus for your profile and administrator settings particularly). 

 

You could trying installing Jira Software 7.12 in a separate environment and importing your xml backup to see if you have the same issues. 

 

I'd like us to take a closer look at your logs to see if all of the upgrade tasks ran correctly too, please look out for an email from our support portal soon. 

 

Cheers, 

Keri

Hi Keri,

thanks a lot for the ticket in the support portal. I will upload our support zip there.

You could trying installing Jira Software 7.12 in a separate environment and importing your xml backup to see if you have the same issues. 

Yes, we also tried this but without success. We build up a Jira 7.12.1 in a separate environment, on the startup we upload our XML backup and we got the same issues in the completely new environment.

Cheers,
Henry

I have resolved it by entering plugin safe mode and then exiting it "but do not restore previous configuration". Then you shall enable manually needed user-installed add-ons  and some atlassian add-ons. JIRA 8.5.2

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you