Class Not Found Exception

Hi,

I am developing a web-items plugin (we'll call x) and have been trying to get past this issue for a while now. I am trying to use methods from another custom plugin (we'll call y). However I keep getting a Class Not Found Exception error when actually using the plugin. It builds fine without errors, but when I go to use the plugin I get the Class Not Found Exception error and the logs say 'y not found by x'

 

I have tried the following:

  • Put the jar of y in the classpath
  • Put the path as an import package in both pom and atlassian-plugin
  • put the path as an export package in pom

 

Plugin y does not have a pom (Its a plugin to link our Jira to Perforce), so I'm wondering if this is the problem.

 

Any ideas on anything else I can try?

 

Thanks,

Eimear

0 answers

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Sunday in Agility

You asked for it, so we delivered: images on issues have arrived

A picture tells a thousand words. And agility boards have just released their latest feature: cover images on issues – so now your board can tell a story at first glance. Upload attachmen...

197 views 2 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you