Class Not Found Exception

Hi,

I am developing a web-items plugin (we'll call x) and have been trying to get past this issue for a while now. I am trying to use methods from another custom plugin (we'll call y). However I keep getting a Class Not Found Exception error when actually using the plugin. It builds fine without errors, but when I go to use the plugin I get the Class Not Found Exception error and the logs say 'y not found by x'

 

I have tried the following:

  • Put the jar of y in the classpath
  • Put the path as an import package in both pom and atlassian-plugin
  • put the path as an export package in pom

 

Plugin y does not have a pom (Its a plugin to link our Jira to Perforce), so I'm wondering if this is the problem.

 

Any ideas on anything else I can try?

 

Thanks,

Eimear

0 answers

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

172 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you