Cannot resolve issue via REST API

Hi all,

I am trying to resolve an issue via the REST API but I keep getting the following error:

Could not find valid 'id' or 'name' in resolution object.

I have used the API to fetch all valid resolutions before-hand so I know I am passing in the correct resolution. I have tried both Name and ID - still get the same error.

The JSON I am sending is:

{
"fields": {
"resolution": "Done"

},
"transition": {
"id": "801"
}
}

Using the following URL:

https://xxx.atlassian.net/rest/api/2/issue/TICKET-10163/transitions

I did read that the resolution field would have to be on the edit form for this to work, but having added it I still get the same error.

Has anyone else experienced this?

Thanks.

 

2 answers

1 accepted

0 vote
Warren Levy Community Champion Oct 04, 2017

Hi Ben

This is the JSON that I use

{
"update": {},
"transition": {
"id": "241"
},
"fields": {
"resolution": {
"name": "Done"
}
}
}

 and this is the call that I use

/rest/api/2/issue/JRA-5475/transitions?expand=transitions.fields&transitionId=241

Thank you Warren! Comparing your JSON to mine I can clearly see now I missed the resolution "name" key. I'll go back to the Java library that generated that code and try and fix it.

Thanks for your help.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

119 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you