Cannot get ApplicationUser

I logged in as the "test_admin" user in JIRA.
I tried to get ApplicationUser using UserUtil.getUserByKey. for the user "test_operator"
It returns null, however "test_admin" has permissions to get information about "test_operator".

I tried the same using rest api
and I managed to get the information.

Why is UserUtil.getUserByKey returning null?
For the other users it works correctly, the problem occurs only with one user.

The User Directory has "Atlassian Crowd" type.

JIRA server - 6.1

Thanks in advance,

0 answers

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,338 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot