Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Cannot create XML backup or access Plugin Data Storage

Jira Server version: 8.19

MySQL version: 5.7.42

OS: Windows Server 2012 R2 (Jira and MySQL)

I get the following error whenever I try to either create an XML backup or access the Plugin Data Storage area of the Jira UI:

java.lang.RuntimeException: Could not read fields for table ao_187ccc_sidebar_link

Caused by: java.sql.SQLSyntaxErrorException: Table 'jira.ao_187ccc_sidebar_link' doesn't exist
at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException( [mysql-connector-j-8.0.33.jar:8.0.33]
at com.mysql.cj.jdbc.exceptions.SQLExceptionsMapping.translateException( [mysql-connector-j-8.0.33.jar:8.0.33]
at com.mysql.cj.jdbc.ClientPreparedStatement.executeInternal( [mysql-connector-j-8.0.33.jar:8.0.33]
at com.mysql.cj.jdbc.ClientPreparedStatement.executeQuery( [mysql-connector-j-8.0.33.jar:8.0.33]
at org.apache.commons.dbcp2.DelegatingPreparedStatement.executeQuery( [commons-dbcp2-2.1.jar:2.1]
at org.apache.commons.dbcp2.DelegatingPreparedStatement.executeQuery( [commons-dbcp2-2.1.jar:2.1]
at [?:?]
at [?:?]

I don't understand why Jira is even looking for the table ao_187ccc_sidebar_link because that is a Confluence table. We do have a Confluence instance running on the same server and same MySQL instance. Jira is the auth provider for the Confluence server (using internal Jira user directory).

I have tried clearing plugin cache and restarting the server.

Please let me know if you can help.

2 answers

1 accepted

1 vote
Answer accepted

For anyone else who may have issues with this I am leaving the solution here:


  • We moved our MySQL instance from one server to another.
  • We re-provisioned the users on the new instance, the grants were not the same; the Jira user on the new MySQL server had full grants (not just those required for the Jira database).


  • Delete and re-create the user Jira uses to connect to the database, granting only the privileges required to manage its database.
  • We did try to remove the permissions and re-grant on the existing user, but this did not work, only recreating the user worked for some reason.
0 votes
Robert Wen_ReleaseTEAM_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Nov 05, 2023

Hi @Robert Wen_ReleaseTEAM_ I should have mentioned in my original post that I have already been through all the KB articles I could find, including the one linked.

That article is for MSSQL (not MySQL), and isn't relevant to this issue, though the error is indeed similar.

Another thing to note is that the referenced table in the KB article is in fact a Jira table, however the one in my issue is a Confluence table that Jira, for some reason, appears to be attempting to reference in its backup process.

This is also not a casing issue (there are other KB articles about issue related to `utf8` encoding), but our instance has correct encoding and charset values.

I have attached screenshots to help make this issue more clear.

Thank you, though!


Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events