Cannot create Stash branch from JIRA

I am running Stash 2.8.2 and JIRA 6.1.1. I have set up application links between the apps, and there are no warnings or errors on the web UI about the links. I can mention a JIRA issue in a Stash commit and the commit will show up on the Source tab in JIRA. Likewise, the JIRA issue will appear as a link on the Stash Commits tab and I can pop open the issue to view and/or interact with it. I cannot create a Stash branch from JIRA, no matter what I do. I have deleted and re-created the application links several times, initiating the link from Stash and JIRA without any change in Symptoms. There is no "development" section on the JIRA issue as described in the JIRA 6.1 documentation. I have checked the permission helper and I have the "View Development Tools" permission for the issue. On the "Commit" tab of JIRA I just see the 3 ads for BitBucket / Stash / Fisheye. If I click on the "connect" button for Stash, I am taken to the application link page where JIRA shows that I have a good connection to Stash. If I go to the project admin page in JIRA and choose "Development Tools", the "Connected Developer Tools" says "Create branch from JIRA is unsupported. Upgrade Stash to use this feature". I've tried clicking refresh without change. I am running Stash 2.8.2, so I'm not sure if the version checking isn't working and JIRA thinks that I'm on <= 2.7.x. There are what appear to be some spurious warnings about i18n in both logs, and about http client thread usage in JIRA.

2 answers

1 accepted

The issue turned out to be related to SSL certificates. I had a SSL cert fronting the server whose CN didn't match the Apache proxy that sits in front of all my Atlassian servers.

On an unrelated piece of work to fix the cert to make the "warning: this site may be blah blah blah" interstitial go away, the create branch started working.

I know that Atlassian servers are capable of complaining about some SSL certificate issues (i.e. if you have a private root CA and don't add the CA cert to the java certificate store, you can't create application links). Those errors appear in the logs.

This seems to be a more subtle failure where JIRA doesn't really like the Stash cert but also doesn't emit anything to the log to suggest to the user that this is the problem.

Hi, I seem to have the exact same issue as you do, but I don't understand what you did to fix it... the root signing certificate is properly imported in the cacerts file, application link seem to work well but I get the same warning about stash being too old even though I'm on 2.8.2.

I restored a backup in a VM and removed all the SSL and reverse proxy shenanigans, and jira and stash do happily connect, so somehow this is related to SSL, but given that I don't have any error message in the log I am a bit at a loss here... My CN on the ssl certificates all seem to be good also, etc...

ok so I did manage to fix the problem, it was caused because I had separate certificates for the subdomains I was using, but they were hosted on the same server (with the same ip address). I fixed it by using a wildcard certificate instead. See this: http://serverfault.com/questions/390657/do-i-need-a-dedicated-ip-address-per-sub-domain-for-ssl

I had this exact problem. I can confirm Nico's solution works. Create a wildcard ssl cert.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,898 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot