The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot connect to IMAP mail server

Ge Bai
August 10, 2014

I tried to configure Jira to connect to our IMAP mail server host, but got "ConnectException: Connection refused: connect" error.

I followed the steps on https://confluence.atlassian.com/display/JIRA061/Connecting+to+SSL+services to add domain cert into the keystore, but still got same error.

Any idea about what might be the problem?

Thanks!

ConnectException: Connection refused: connect

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Nic Brough -Adaptavist-
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
August 10, 2014

That error means the server is there and listening, but is not set up to accept connections, either from your server, or from the user you tried to use (or both).

Try a telnet to that server and port and see if you can log in. But whatever you do, you'll need to talk to your IMAP server admin

Ge Bai
August 11, 2014

The host name I am trying to connect to is the load balancer not the name of the client access server. Is JIRA load balancer aware?

Thanks!

Nic Brough -Adaptavist-
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
August 11, 2014

It shouldn't matter. A load balancer will be presenting a consistent name and interface, even though the request may end up being handled by different servers or services.

The problem is that you're account is not set up to log in to the imap servers, or you can't reach them

Ge Bai
August 11, 2014

Thanks Nic for your reply!

I tried to make JIRA connect to one of the IMAP servers behind the load balancer, and it succeed. But when I switched back to host name, which is a array of three servers, it failed again.

Any suggestions?

Thanks!

Nic Brough -Adaptavist-
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
August 11, 2014

There's something wrong in the setup of the load balancer. Jira REALLY doesn't care what's behind the host/user/password details, as long as it responds as a standard imap service.

TAGS
AUG Leaders

Atlassian Community Events