Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Cannot change project lead

I believe I've reviewed every post and tried every option going back several years without success. We used to be able to do this (although even then was a bit of an adventure)

Bottom line: the dialog below looks like my best chance of success -- but where are the users?

Users are in the project, the project has other admins (besides the overall Jira admins).

For any devs at Atlassian -- what is the logic that populates my options here?

At a loss.



Using Server Jira v8.6.1

2 answers

1 accepted

7 votes
Answer accepted

You may already have done this, but note that you must start typing to get an auto-suggest list.

Tail between legs. Shoot me. That did it.

Ha ha, happens to the best of us! :-) 

Like erica_dahl likes this

thank you for asking this question.  I was having exactly the same problem and found this question in the "related questions" links to the right.  

I feel like this is a new thing too because I've been changing project leads for months

I was having exactly the same problem too. I think this is definitely UI/UX design issue

Like # people like this

Yes thanks Jeff for researching and posting this. Tripped me up for a long while today. Agree with jeepkd - very poor UX on this screen from Atlassian.

Like # people like this

Thanks - I've been stuck on this for days!  I swear that I've also tried typing names before but it worked today.

This solution doesn't work for me.  I cannot type over the existing name at all.

I'm an administrator using JIRA v8.11.0 and followed the advice about using Edit Defaults then just type in the Project Lead field until the required name is auto-suggested. Then hit the Update button and the Edit Project Lead and Default Assignee for Project pop-up box disappears to leave me on the Project Lead > User and Roles screen and the Project Lead entry alters to Default Assignee. Refresh the page and I'm back to the original set up and nothing has changed. 

Alternatively, if I change the current Project Lead role to unassigned and return to the Edit Project Lead > User and Roles screen the Project Lead entry alters to Default Assignee.  On clicking Edit Defaults both the Project Lead and Default Assignee are blank and labelled Select.  I type the name of the relevant person and choose from the auto-suggest list, then click Default Assignee and choose Project Lead.  This time when I hit Update nothing happens - it remains there and I'm unable to commit the changes.

Hi @mark_smith-magee I'm having the same issue. Were you able to successfully update the Project Lead?  If so, how?  Thanks!

Same problem. Did anyone find a resolution to this problem?

To change the project lead for the JIRA server, the following works for me. 

Project Settings > Users and roles > Edit Defaults (link on upper right-hand side)

Click on the drop-down list under the project lead text box, you will see the old name first, and then start to type the new name in that box, and it will overwrite the old name, so you can change the Project Lead there.

Hope it helps.


Like freatt likes this

Hello, yes it is correct.

It worked for me too thanks.

Like mark_smith-magee likes this

@Susan Kirby Corder - Yes thanks, once I followed the advice @Betty Li gave. Thanks very much Betty.

None of the suggested solutions worked for me, I'm Project and Jira Admin, and i'm trying to change lead to another project admin, i tried slow typing the name, and also using email, but all i get is a "no matches" sign. I've also tried typing the name of any of the other project users. Even if i try to type the name of the user who is lead right now, it also gives me the "No matches" error.Captura de Pantalla 2021-09-29 a la(s) 16.24.02.pngCaptura de Pantalla 2021-09-29 a la(s) 16.25.26.png

Like # people like this

I got the user's atlassian id from the users page, pasted it into the search field, clicked Update and it actually saved.

This is abhorrent.

Agree with previous commenters. It's bizarre and un-intuitive that no options show up in the drop-down. This is unlike any other user selection drop-down in Jira and explains why so many Admins are here commenting on this post.

Like # people like this

Global perms, browse users. A proper application would tell you why things are weird, not just leave you wondering with a broken page.

Like # people like this

I have tried the following steps and still not able to see any other user under drop-down selection for me to change the name of the project lead.  I cannot even edit the field in the Project Lead.  Can anyone further advise?  Thanks.

Project Settings > Users and roles > Edit Defaults (link on upper right-hand side)

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you