Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't upload images!

Copy + Paste is not loading images. It looks like it works, but then a placeholder image appears in the Attachments section. Nothing appears in the comments.

 

Attaching a saved image file results in the same issue.

 

Anyone else having this problem right now?

22 answers

I am starting to have this issue again. It had subsided for a couple days but back aaaagain :(

Me too. Unable to paste an image in the comment.

Same here. I find that when I take a screenshot (.png) on a Windows laptop, send it to my MacBook and then upload that to a comment in Jira, works just fine.

However, when I take a screenshot using my MacOS screenshot tool (.png), my upload to a Jira comment fails. When I hit "Retry" the image appears it might have uploaded (other than being slightly grayed out) but hitting Save just results in an error and gives me the option to retry again. Screen Shot 2020-04-17 at 7.02.46 PM.pngScreen Shot 2020-04-17 at 7.02.57 PM.pngScreen Shot 2020-04-17 at 7.03.12 PM.png

Like Polus Qa likes this

JIRA cloud will let me (begrudgingly) attach images to bugs, but the Save button is greyed out any time I try to upload an image into a comment.  The upload works (gets an error at first but eventually retries OK, but I can't Save the resulting comment.

step-1.png

Then:

step-2.png

Then finally:

step-3.png

Note that I can't save, despite the fact that the image is showing OK.

My experience as well. The feature remains broken no matter how I try to include an image.

Like # people like this

this is my experience as well. its so frustrating

Like # people like this

I was able to finally add images to a JIRA issue's comments by editing the comment itself hours later and using the Upload Images dialog (the same dialog that didn't work when creating the comment). This is certainly not consistent or reliable behaviour and needs to be fixed across the board.

Like # people like this

Got it.  So I need only add critical information to a comment well after it's needed.  Great :-/

Like Howard Kistler likes this

This 'workaround' isn't working for me...

Actually, I tried using Firefox (instead of Chrome which I usually use) a minute after typing this, and it worked then.

I'm using Firefox most of the time, so that may be why my hack worked. Still, I'd rather have it fixed properly. It's frankly a mess.

This is our experience on the next gen boards as well, save button is greyed out. Same user can add images in comments on original format projects with no issues.

This is happening to me as well, I wonder if all of us here has recently accepted JIRA Software "New Look" ? 

That's when it started happening to me. I switched back to the old view on a ticket (from the menu in the top right) and was able to upload an image just fine. Then I switched back to new view and was able to view image.

4 votes
Owen Wallis Atlassian Team Apr 21, 2020

Hi everyone,

I'm the Product Manager in the Media team at Atlassian. I look after the attachments and images experience across Jira and Confluence.

Thanks everyone for your comments. I totally understand the frustration. Especially at the moment when many of you are working from home, balancing work with looking after children, or are worried about your jobs. Having such a key piece of functionality not working is not great at all.

The feedback you gave me here helped me push for a fix with the Jira team. As of 10pm Sydney time last night we put up an initial fix for the upload issues you've been seeing. I checked the analytics again this morning and it appears to have resolved many of the issues.

We do have another fix that the Jira team are helping us on which we think should resolve the final set of upload issues we are aware of. These relate to when you leave a browser window open for a long period of time, come back and try to upload, but then see the upload fail. We added in a similar fix for Confluence recently which greatly reduced upload issues so I'm hoping we'll have the same success in Jira. A fix for this should be coming in the next couple weeks. In the short term refreshing a page which has been open a long time before uploading is the workaround.

Again my apologies for the frustrations around uploading. Specifically in the last couple weeks things have got really bad. I'm sorry it took so long for us to identify this.

On a side note I know many of you are having issues with the attachments experience when viewing issues. We are actively working on improving this. We're working on a table view for attachments in Jira, we're working to fix previews for Microsoft Office file formats and other files which currently fail to show a preview, and we're working on adding more useful context to the thumbnails of attachments that you see in issues.

If you'd like to talk to me on the above, or on any other issues related to attachments or Media then please feel free to find a time with me: https://calendly.com/owallis/

Thanks

Owen

This functionality was working again for me at around 11 pm AEST, so thank you.

Like Owen Wallis likes this

The communication is greatly appreciated, thank you!

Like # people like this

I'm still having this issue with the new UI. Has the fix you mention been applied everywhere?

I'm able to upload just fine when I switch to the old UI.

Owen Wallis Atlassian Team May 12, 2020

Hi Brexton,

The fix I mentioned relating to the final set of upload issues started rolling out last week. We are progressively rolling out the change to make sure there are no issues.

So, all going well with the rollout, it may be another week or so before the change is on your Jira instance.

Apologies for the delay.

Owen

Like Brexton Popejoy likes this

Looking forward to the fix, thanks!

As of May 25, I'm getting the problem. Is roll out still in process? BTW, works fine in old view.

Owen Wallis Atlassian Team May 26, 2020

Hi @Andrew McKay,

Yes we're rolled out to 100% now. Apologies you are still having issues. We know we still need to work on improving the upload experience.

I'm based in Sydney but if you can find a good time to talk I'd be happy to learn more about your setup: https://calendly.com/owallis/

If you can't find a time, then learning about your browser/device/connection/timezone/Jira instance might help the team here diagnose the issues you are facing.

All the best

Owen

Ben Ashby I'm New Here Jun 29, 2020

Just letting you know that I have been using the 'new' view without issue for a while (this is a new job for me, but used it in my previous role as well) and the images uploading has been absolutely fine when creating new tickets, when I've had to attach multiple files (4 x jpeg images) on a comment, the upload issue come up again.

I switched back to the 'old' view and could successfully attach the 4 images.

Just letting you know that apparently there are still gremlins in the system!

Owen Wallis Atlassian Team Jun 29, 2020

Hi @Ben Ashby thanks for this. Also for @Andrew McKay (and any other interested parties).

You are quite right, unfortunately we didn't catch the token expiry issues everywhere. The Jira team are adding in a fix to files uploaded via the description or comments of tickets on the 'view issue screen'.

This should be done in the next couple weeks and then will be rolled out soon after.

My gut says this should fix the problems you are having. I think it is when you leave a ticket open for a while and then come back to upload - the authentication token to say 'sure, this user can upload to this ticket' expires. Hence no upload allowed.

Hope this fixes it for you both. Apologies again on the time it has taken to diagnose this.

Hi Owen,

Thanks for all your attention! Very much appreciated. "...leave a ticket open for a while and then come back to upload": yes I believe this is accurate. Can't wait for the fix.

 

Thanks,

Andrew

Like # people like this
Ben Ashby I'm New Here Jun 30, 2020

Yep that's pretty much spot on, and I echo Andrew's reply of "Can't wait for the fix"!

 

Cheers!

Like Owen Wallis likes this

FYI this is happening again... Not sure if the planned fix has gone out yet, but I cannot drop photos into the body of the ticket, cannot edit a ticket that has a photo already in it (save is grayed out), cannot add photos to comments, etc. 

Like Michael Cappuccino likes this

I can confirm the issue is still occurring.  

Hello Everyone, This is happening to me , I can not attach any picture in my stories/issues.

 

I'm running the new view

"We do have another fix that the Jira team are helping us on which we think should resolve the final set of upload issues we are aware of. These relate to when you leave a browser window open for a long period of time, come back and try to upload, but then see the upload fail"

 

This doesn't seem to be fixed, I still have exactly this problem over the last few weeks (if not longer). As described, uploading a file as part of a comment fails if the tab has been open for a while, but refreshing fixes it. This is super annoying.

Our client are also facing this issue again. Please do something as this really not serving our customers, time consuming to add attachments ourselves and not 2020 at all.

John

I'm having the same issue - can't find a solution currently. 

Have the same issue - can't upload images in comments.

P.S. What the hell is going in Atlassian last years? I know it sound unprofessional but it's not the first issue which I face when using Atlassian products, and these issues have been there for years! Seems like nobody cares. 

I am also having the same issue. No one found a fix? :(

2 votes

Experienced these too:

* dragging/dropping an image into the edit pane gives me the 'Failed to load' empty image box. 

* uploading the image and then inserting it shows the image but disables the save button for the comment

 

I did a hard-reload of my browser  (ctrl + shift + r) and it resolved the issue for me.

 

(chromium v84 + ubuntu v18.04 + jira cloud)

ctrl-shift-r worked for me.

I'm experiencing the same,

  • trying inline copy/paste in new issue view ("failed to load" message),
  • have also tried clicking on the image icon and uploading from my pc (looks like it is uploading but never saves the image),
  • have tried Chrome and Firefox.   

Two images I uploaded previously have the greyed out preview placeholder like Lisa mentioned.  If I click on the placeholders it expands to see the image.

I put a bug in with Atlassian and they responded that this is a known issue and they are working on it.  This is a link to their support issue https://status.atlassian.com/incidents/hr2vwvt9lfbh

Like # people like this

They say it is fixed but I still can't copy/paste inline.  Paper clip attachments are fixed.

Has there been any progress on this? I am experiencing the same issue with the confluence cloud and the link to the issue provided by @David Elger seems to be dead.

Like Michael Marron likes this

I'm having the same issue with the cloud version

I am also having the same issue still

Same problem, JIRA cloud - can't attach pictures to either the issue, or the comment field.

Still cannot attach a simple image to a comment or a story in Jira.

I tried the copy/paste and the attachment method, neither work.

This is a basic feature that is not working.

I'm also having this issue when I use Chrome. If I use IE11 it works fine, even though I got a notification saying IE11 isn't supported by Jira anymore.

I'm not able to upload images, attache files to a ticket in the description nor on comments either. This is really impacting productivity and efficiency. Hope this can be fixed soon!

FUCK YOU jira. You are making my work terrible. For the money you got I would expect perfection. Instead I have some flushy ajax style for everything so the page loads forever and it doesnt work half of the time. You are discgrace and if it would be on me I would just sue you. Do you know how much time have I lost because I had to refresh page and reupload half of the images? Which I do by printscreening so ussually I didnt have the older ones anywhere? Fuck you, you are doing terrible job. Fuck you the third time.

What I did and worked for me, was drag and drop directly to the comment (.jpg) and then save. 

This worked for me, thank you.  browser: firefox, attachment: .png

1 vote

My issue just started within the last week. I noticed that this issue has to do with refreshing the page. If a perceived change is made to the background page it won't let you input an image until you refresh the page. Thankfully the comment saves so all is not lost. 

This is also happening for our instance. We can drop photos into the body of the ticket. However its greyed out and cannot save. 

Our clients are also facing this issue again. Please do something, as this really not serving our customers, time consuming to add attachments ourselves and not 2020 at all.

John

Having exactly the same issue, Chrome on macOS with screenshot .png files.

This irritating behavior still continues when editing comments.

JIRA v7.3.0 + Windows 10 1909 + Chrome Version 83.0.4103.116 (Official Build) (64-bit)

Copy + paste and image, the image shows in the edit box.

 Save the comment image turns in to Unable to render embedded object: File (image-2020-07-06-08-56-57-764.png) not found.

I cannot use drag+drop, because that requires saving the image to file, whereas my use cases most of the time are screenshots.

Having the exact same issue this week, had been working again previously.

Now, have to save screenshots and then drag and drop.  The paste didn't work, and none of files I had attached to the comment uploaded when save was clicked.

We are having the same issue. When you insert a picture, the "Save" button gets grayed out. If you try and copy/paste, it says "We couldn't save your comment. It might be empty or have invalid formatting."

It happens for us as well, issue seems to be here POST https://api.media.atlassian.com/upload/createWithFiles <-- returns a 500

Gabriel, I'm not sure if you've noticed yet, but images seem to have been fixed.  We can upload again now.  

Like Lenin Gómez likes this

Thanks Jeremy, I was getting that error for about an hour or so, and noticed it was sorted eventually. But this seems to be reoccurring every now and then and it's affecting a number of people. Would be nice to get an explanation from the Atlassian team. Whatever caused the issue happened in that API endpoint.

This seemingly appears to be an auth token timeout problem between services.

If you reload the page, upload works as expected.

If your tab/window has been open for a while, then this error occurs again.

0 votes

Some of our users are also having this problem. Copying and pasting an image results in a broken image link after the save. Does not matter if user copies and pastes into a comment, into the description or tries to add it as an attachment. 

I don't have this issue from my machine, so I'm trying to troubleshoot the differences between us as far as browsers and tools we're using to capture the images (Snagit versions, etc.)

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you