Can't see Xray dropdown menu in the general top menu of Jira

ליאור בראודה March 22, 2023

Hello, I am using Jira data center v8.20.7 and I have tried to upload Xray for jira version 6.4.0

When uploaded xray it did not add a dropdown menu in the general top menu of jira so I could not access the xray at all.

Please help me understand what I can do to fix it, thank you in advance!

1 answer

1 accepted

1 vote
Answer accepted
Stefan Salzl
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 24, 2023

Hi @ליאור בראודה 

Was this a fresh installation or an upgrade? What is your installation file called? Could you send names/screenshots?

Where did you download the file? Please double check if you chose the correct file as there are different downloads for Server & DC and even for Jira major version (8 & 9) --> see screenshot from market place:

image.png

Best
Stefan

ליאור בראודה March 25, 2023

Hello @Stefan Salzl , thank you for answering

While this was a fresh installation, we have a test instance on which we tested the Xray app first and everything worked there fine.

Our installation file is called is xray-6.4.0.jar.

Sadly, We are unable to provide screenshots.

We downloaded the file on the Atlassian Marketplace site.

Stefan Salzl
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 26, 2023

Hi @ליאור בראודה 

to wrap this up:

the test instance was set up first with exactly the same versions and files. in the test system it worked fine and after installing the same setting (versions/files) in a production environment (which is also configured exactly as the test environment) it doesn‘t work anymore?

Best
Stefan

ליאור בראודה March 26, 2023

@Stefan Salzl , yes this exactly what happened.

Could you help me please understand what should I do to fix it?

thanks again🤍

Stefan Salzl
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 27, 2023

Hi @ליאור בראודה 

I´m kinda curious bc I can´t find a version 6.4.0 in the market place. Could you maybe provide a link?

Furthermore:
regarding to the release notes of 6.4.1 on xray website it points out there was a blocker issue in 6.4.0:
https://docs.getxray.app/display/XRAY/Xray+6.4.1+Release+Notes
https://jira.getxray.app/browse/XRAY-9011?src=confmacro

I could imagine that this version therefore has been taken offline. Could you maybe try to install the fixed version?

Best
Stefan

ליאור בראודה March 27, 2023

Hello @Stefan Salzl 

IMG-20230327-WA0005.jpgThis is the version we uploaded, I think you are looking in the cloud version releases because I can't see 6.4.1on the data center release history :(

Stefan Salzl
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 27, 2023

Hi @ליאור בראודה 

I see all versions of all hosting types here:
https://marketplace.atlassian.com/apps/1211769/xray-test-management-for-jira/version-history

image.png

 

Could you guide me how to get to the version you mentioned or post the link here?

One further question:
Where exactly did you expect xray-button to appear? did you check the installation in the administration console under "Manage apps"?

Best
Stefan

ליאור בראודה March 27, 2023

@Stefan Salzl you are right, I no longer can see the version I downloaded🫥 I will try to download 6.4.1, and maybe it will fix it.

thank you so much for the help!

Like Stefan Salzl likes this
Stefan Salzl
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 27, 2023

Hi @ליאור בראודה 

You´re welcome. Please let us know if this helped you and answered your question. In this case please consider to click the accept button next to the answer in order to mark this question as solved. This will make it easier for other users to find applicable solutions to their problems.

Best
Stefan

ליאור בראודה March 28, 2023

Hello @Stefan Salzl , I downloaded xray 6.4.1, and now the same problem occurred in the test environment which it worked in before.

Do you have any idea what I can do now?

Stefan Salzl
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 28, 2023

Hi @ליאור בראודה 

In your original post you wrote:

did not add a dropdown menu in the general top menu

Where exactly would you expect to occur any menu item? could you send a screenshot of your test instance what it should look like?

 

Please also answer questions from one of the previous posts:

Where exactly did you expect xray-button to appear? did you check the installation in the administration console under "Manage apps"?

Best
Stefan

ליאור בראודה March 29, 2023

hi @Stefan Salzl ,

I am adding a photo of the jira navbar on our test inviorment, unfortunately I don't have a photo of the xray "Tests" button that should appear but we have zephyr and it should look the same

20230329_104121.jpg

I also checked the installation and I didn't see anything out of the ordinary or something that is off, it looks like it was uploaded correctly.

Stefan Salzl
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 29, 2023

Hi @ליאור בראודה 

A button in the menu isn´t a real inidicator of your installation. I don´t see an xray button in my system either but xray is installed and I´m using it.

Still questions are not answered yet:

  • do you have admin permission?
  • did you check the installation in the administration console under "Manage apps"?

 

Best
Stefan

ליאור בראודה March 29, 2023

hi @Stefan Salzl 

I have admin permission and I checked the installation, however I think o found what was the problem.

so I will check on Sunday and will notify you if it worked or not.

thank you so much for the help🤍

Like Stefan Salzl likes this
Stefan Salzl
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 29, 2023

Hi @ליאור בראודה 

thanks for your feedback. Great to know you got an idea. Curiously looking forward to your solution.

Best
Stefan

Stefan Salzl
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 12, 2023

Hi @ליאור בראודה 

just wanted to check in on this issue. Could you check the solution?

In case your problem is solved please hit the accept button to the answer or in case you got your own solution please be so kind to post this solution as an answer so that this can be accepted and the question can be marked as solved.

This makes it easier for other users to find appropriate solutions when they are faced with same/similar problems.

Best
Stefan

ליאור בראודה April 12, 2023

hello @Stefan Salzl 

sorry I forgot to update, we managed to fix the problem.

thank you so much for all the help❤️

Like Stefan Salzl likes this
Fabien HEGRON
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 30, 2024

Hello @ליאור בראודה 

 

I have a similar problem with the integration of XRay in Jira, could you explain what did you fix ?

 

Thank you

Suggest an answer

Log in or Sign up to answer