Can't get JIRA gadgets to show in Confluence pages

We are a licensed Jira customer (2000 users). We are doing an eval of Confluence to demonstrate the awesome integrations between Jira and Confluence. My goal is to demonstrate to senior management that Confluence is a better social tool for our Agile teams than the alternative (SharePoint).

The one key piece of the integration that I can't seem to get working is Jira gadgets. I've got the app links setup in both apps and I've got confluence configured to recognize each of the gadgets I want via external gadgets.

When I edit a page, I am able to see the gadgets when I add a macro to a page, but the previews don't work and the gadgets don't display on saved pages.

So far I've tried greenhopper-project-dashboard, greenhopper-card-view, greenhopper-rapid-view, structure-gadget (from structures plugin), and gantt:gantt-gadget (Gantt chart plugin). All misbehave to about the same extent.

We are using Jira 5.1.4 standalone (behind https) and Confluence 4.3.1 (behind http).

I've trolled the logs on both Jira and Confluence and can't see any smoking guns.

Can anyone help?

8 answers

1 accepted

With Atlassian support's help, we got it working using application links, gadgets feeds, and server base URLs that are all configured with the IP address rather than the server name in both Jira and Confluence. I haven't tried converting the configs back to server name and I haven't yet tried re-introducing SSL.

The other key was making sure the gadgets are working on a Jira dashboard before expecting them to work in Confluence (my bad). For example, we are using GH 6 and some of the GH gadgets that use "classic boards" don't work in either Jira or Confluence.

Same problem. Do anybody have a workaround.

I have a feeling this is probably to do with the SSL on your JIRA instance.

We have a similar setup: JIRA 5.1.2 (https), Confluence 4.3 (https) and Structure plugin. Intially I ran into problems with the JIRA issues macro not working properly in Confluence pages.

You need to make sure the certificate from JIRA is imported into the Confluence cacerts keystore.

You can use a plugin to do this, or:

  • open JIRA in Firefox, view site information & then use Certificate Viewer to export the certificate
  • Save the certificate to your Confluence server
  • Import the certificate into the Confluence cacerts

Hope that helps.

that might be the problem if you use SSL. In my case i don't use SSL.
Both Jira and Confluence are on same server, they have different context path to separate them.
I can import Jira Issues but i am unable to export 'Jira gadgets' into Confluence. It just shows white space in place of the gadget.

I have the same issue. I have tried to solve this before with no success, but decided at the weekend to give it another go with new versions of the products. I have Jira 5.2.1 and Confluence 4.3.5, both are standard installations running on the same server using http. All communication with the outside world is done via HTTPS using mod_proxy on apache. Apache is running on a different server. The application links are done via the external address and seem to function properly. The SSL certificates have been added to both cacerts files. Both applications appear to work perfectly in all respects except for sharing gadgets. I am authenticating against Crowd SSO set up to authenticate against our Free IPA LDAP directory.

Attempting to add a gadget feed in Confluence gives the error:

Cannot connect to host at https://jira.example.com/rest/gadgets/1.0/g/feed.

attempting to add any individual gadget gives the message:

Invalid gadget URL

Manually accessing either URL in a web browser shows what appears to be good XML.

Whitelists in both systems are set to allow any URL.

The IP Address Filter in both incoming and outgoing trust definitions in both systems is set to 127.0.0.1 192.168.0.* and the external address of the internet gateway (an ADSL router). The allowed URLs for incoming on Jira and Outgoing on Confluence are set to:

/rest

/plugins/servlet/streams

/rpc/soap

/sr/jira.issueviews:searchrequest

/secure/RunPortlet

The outgoing allowed URLs on Jira and incoming allowed URLs on Confluence are set to:

/plugins/servlet/applinks/whoami

/plugins/servlet/streams

I have checked both logs and no messages appear in either of them either good, bad or indifferent The logs do not change at all as a result of the attempt to add the feed or individual gadget.

The operating system is CentOS 6.3 x86 with all updates applied. The Atlassian applications are the only software that are not provisioned from the standard CentOS 6.3 repositories.

I am at a loss, so any help would be gratefully received!

I have the same configuration as Simon Williams here and am running into the same exact issue. I have even upgraded a test Confluence to 5.1.3 and am still getting the same problem over SSL. And yet, Atlassian support has referred me to this post as a "possible solution".

I am going to have a screen sharing session with a escalated support Engineer today to try to figure this out. I will post back when i get more information.

In the mean time, if anyone has figured this out, any information will be very useful. Thanks.

Hi all,

I've been working with Atlassian support on this for the past few days. As part of the troubleshooting we removed SSL from our Jira instance. Still no dice. I have a call scheduled with them at 9:00 am PST today.

The state of the troubleshooting is being recorded on my support request here:

https://support.atlassian.com/browse/CSP-94031#comment-3216073

I'll report back when we get it resolved.

Tom

We were able to get it working for our instance as well. You have to first ensure that all the certs you are using have the correct hostname as the Common Name, or the "First Name and Last Name" if self-signing a cert using keytool, or in the DNS section if using a SAN cert.

Here are the basic steps that i took to get this working for us. (Note: we have an internal CA which we generate certs from)

  1. Export CA and Sub CA certs
  2. Export server cert from both JIRA and Confluence (most likely not needed, but won't hurt)
  3. Import CA and Sub CA certs to the cacerts keystore in both JIRA and Confluence (install dir\jre\lib\security\cacerts) using keytool.exe
  4. For good measure you can import the server certs into the opposite applications cacerts keystore in the same way as step 3. This I proved is not needed if you have a CA and Sub CA certs in there, because it will automatically trust a cert if it was generated from the Sub CA or CA. That way you don't have to worry when certs expire you can just gen a new one, and it will still be accepted without having to import it into the cacerts keystore.
  5. Restart both systems
  6. Ensure both systems are running over https and you can connect and navigate correctly
    1. I configured ours using a reverse proxy via IIS and ARR (Application Request Routing)
      1. These instructions are elsewhere on a Confluence is slow via reverse proxy question
    2. I also tested this by using SSL over Apache Tomcat and it also worked
  7. Change your Site URLs in both systems to represent the new HTTPS urls
  8. If you already had application links between the systems, you should do some firewall, or application restart magic to get the "Relocate" option for the application link. Then you can just change the URL to the HTTPS one.
  9. If you do not have application links configured yet, configure your application link pointing to the https URL (Proxy hostname if using a reverse proxy like i did)
  10. Add the external gadget feed to confluence by pointing to the full https url.

Those steps worked for me and everything is working beautifully. Let me know if you have any questions about these steps, i will be happy to help.

Additional Note: I did NOT configure any IP patterns or URL patterns in any of my application links. They just seem to get in the way and actually cause more errors and warnings in the logs.

I can't imagine how did you get this working. We set our Jira and Confluence behind NGINX (for HTTPS reverse proxing). Atlassian suggested to configure additional Connector in Tomcat (additional ports 8081 and 8091) for Application Link to work but after certificates were added properly (CA and Sub CA and fqdn certs) I managed it to get running without it. But no matter how I try it (Gadgets feed URL) Confluence cannot connect to host https://jira.company.co. If I reconfigure Base Url to use IP and non-https port everything works but if I change Base Url to https://hostname it doesn't work. If I run curl from confluence server to request gadget XML over https it connects properly and gets information, no errors. Any thoughts?

Kalle, I have exactly the same problem and the same architecture. If you find a solution, please share it with me. Thanks.

This is kinda an old thread but be sure to watch your js console output. If you've just recently switched to SSL you may still have mixed content warnings from HTTP-based external gadgets.  Remove them all or convert to HTTPS. These WILL block other gadget-based macros from showing including some JIRA one's, particularly third-party add-ons.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,224 views 14 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot