Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't add apps after migrate local server to cloud

Edited

Hi,

I have a problem when i want to download any app. I can download only 2 apps (CLI and Portfolio) after migrate. I can download all apps before migrate my instance server to cloud. But when i finished to migrate, i can't download any apps. For information, i use XML Backup to migrate my local server to cloud.

The message  when i want to add an app is : We ran into a little trouble. It might just be a hiccup. Try again in a bit.

Cordially,

4 answers

1 accepted

I've got answer from Atlassian Support. The cause is described as follows:

Checking the Jira Cloud instance at xxx.atlassian.net, I can see that the imported groups have not been approved yet, which contributes to the issue of not being able to install Apps (Plugins). The reason for this is because when Jira attempts to install an App, it will try to provide the App's System user with product access to Jira Software, however, due to Jira Software (or Confluence) not having any default group, the installation of the App fails.

You will need to navigate to the Product Access page (Administration -> Product Access), and click on the "Review imported groups". Once you have a few groups Approved, set at least one of the groups to be the Default Group, and please kindly retry to install the Apps. 
---
So, after dealing with Default group I was managed to install the plugins.

Hope, this helps you, as it helped us.

This helped, thank you Oleg. The error message is way off.

This was exactly my issue. These steps solved it for me. Thank you!

Like Shannon Phillips likes this

This has not solved it for me,  I am trying to re-install a cloud app that was previously installed from the Marketplace then uninstalled.  Now I get this error when I try to install it.  

Under Administration->site settings->product access 

my default is Jira-software-users

Like # people like this

Same problem here, does anyone have a solution? I reviewed the group but that didn't solve it

We solved the problem, thanks to Tempo Support Team. Maybe this is also helpfull for other users.

"The reason why you are then unable to install Tempo, is because your JIRA instance URL and client key already exist in our instance registry and we do not allow duplicate installation to avoid mixing data/instances."

Tempo support team disabled our older key and now we can install Tempo again.

Thanks for this reply, I'll contact Tempo to get our keys destroyed. Cheers.

Hi David,

 

Cloud and server add-ons are totally different by their architecture: jar files for server and services, which just provides atlassian-connect.json for cloud. So you can download jar file for server and upload it, while you can't download service for cloud - you can just specify Atlassian Connect app descriptor URL for cloud.

i misspoke maybe, i would like to add somes applications since the marketplace (https://marketplace.atlassian.com/apps/1212265/svn-gateway-subversion-links-in-jira?hosting=cloud&tab=overview&_ga=2.79080733.864655417.1551859374-809223840.1544107577 for my part) but this message appears when i try to add apps. In the audit log, i have this message: Failed to install app plugin.8810866029982250699.atlassian-connect.json

Any updates? I'm running into the same issue unfortunatly...

Like # people like this

We have the same issue. It appears on adding ANY application to migrated instance, even never used before. So the add-on backend structure mismatch is not likely to be the cause.

Experiencing the same problem as reported by  nic brough_adaptavist  we are exclusively only Jira cloud

Any solution?? I did all the procedures and the error still continues.

0 votes

Try adding the applications by searching the marketplace, rather than uploads.

I have this problem when i want to add the applications in the marketplace with this message: We ran into a little trouble. It might just be a hiccup. Try again in a bit.

In the audit log, i have this message too: Failed to install app plugin.8810866029982250699.atlassian-connect.json

I have exactly the same problem. Is there any solution? I want to use the Insight app (and pay for it), but in combination with a free service management subscription I don't have atlassian support. I Have no idea, how I could fix this without Atlassian support. Even if we delete all jira products and reinstall them, without data restore, I can't reinstall the app.

I made the fault to install the app and migrate the server data from our on-prem server. I had to uninstall the app before migrate the data.
But there was no warning about that.

Any idea how to proceed?

Whatever the blocker to install on the marketplace is should be transient, you should leave it a few minutes and try again.

Hi Nic,

thanks for your comment, but I tried it over a week. 

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you