Bulk upload error with Story and sub-task

We use to use the same template to upload Story and Sub-task, starting from week of Dec-25-2017, it doesn't work with error shown.  Anyone has idea what happen?

 

First few columns in the upload template 

Issue TypeIssue keyIssue idParent idSummaryDescription
Story 1 Sample Summarystory
Sub-task  1Sample Summary-subtasksubtask

JiraUploaderror.jpg 

1 answer

0 votes

As the error states that 'parent issue cannot be null', I'd review the csv file used for the import, looking for subtasks with no value in Parent Id column.

...or substasks pointing to a number that doesn't match a Story Issue id in the same csv file...

This file is to create a new story and subtask under 'Software'.  Therefore, we assign 1 in parent ID and set 1 also in subtask by referring to it.  What the latest we find is we can upload even encoutnering the error.  Just can't pass the validation right now.

Issue TypeIssue keyIssue idParent idSummaryDescriptionRequest TypeRequest by departmentAssigneeReporterPriorityEnd DateDue DateOriginal EstimateComponent/s
Story 1 Summary-storyStoryNEWMISjimlinjimlinMedium16-Feb-1816-Feb-18432000Configure Price Quote
Sub-task  1Summary-subtaskSubtaskNEWMISjimlinjimlinMedium31-Dec-1731-Dec-175184000Configure Price Quote

It's difficult to read that csv... What character are you setting as the column separator? I would suggest using a semicolon ; as the separator.

If the separator has not been properly set, maybe some values could be assigned to a wrong column, therefore causing errors because of apparent omissions.

Another possible cause might be related to the Component/s column, as the JIRA field supports multiple values. In case you would like to set more than one component at once, each of those components should be included into different columns, usually with the same name.

Finally, your screenshot shows a link with the text 'download a detailed log'; may you click on it and post that log here?

I'm running through the same error; My Issue ID and Parent ID columns are configured correctly (each subtasks' Parent ID being assigned to their Story Issue ID), and JIRA keepy saying "Fatal error during import: Parent Issue cannot be null".

 

Here is the extract of the Log of the detailed log discussed earlier:

 

2018-01-04 16:38:14,832 INFO - Importer started!
2018-01-04 16:38:14,846 INFO - Engine is running in Validation-only mode
2018-01-04 16:38:15,046 INFO - All issues will be imported to project: TestTemplate (TTEM)
2018-01-04 16:38:15,063 INFO - Creating issue: [externalId='1', summary='test']
2018-01-04 16:38:15,206 INFO - No problems found with issue 'test'
2018-01-04 16:38:15,212 INFO - Creating issue: [externalId='2', summary='test 2']
2018-01-04 16:38:15,218 INFO - No problems found with issue 'test 2'
2018-01-04 16:38:15,287 INFO - Creating issue: [externalId='3', summary='test 3']
2018-01-04 16:38:15,296 INFO - No problems found with issue 'test 3'
2018-01-04 16:38:15,301 INFO - Creating issue: [externalId='4', summary='test 4']
2018-01-04 16:38:15,308 INFO - No problems found with issue 'test 4'
2018-01-04 16:38:15,314 INFO - Creating issue: [externalId='autoid-7878989984070602626', summary='ST test 1']
2018-01-04 16:38:15,326 ERROR - Fatal error during import: Parent Issue cannot be null

Hi Silvia,

It seems there's a bug in the non-admin "Import issues from CSV" when there are too many subtasks associated to the same parent:

https://jira.atlassian.com/browse/JRACLOUD-65048

The workaround is using the CSV import from the "External System Import" i n the Admin area, accessible from this URL:

https://<YOURS>.atlassian.net/secure/admin/ExternalImport1.jspa

Hope it helps.

Hi Thanks, we will try those suggestion

 Thanks @Ignacio Pulgar [Tecnofor] , the workaround worked.

However, I get the error regardless of how many tasks I am trying to import, if I only import epics, it works, but as soons as I add stories and subtasks, it fails.

Lukily I have access to the admin area, but it's far from a nice solution.

Hoping Atlassian will fix this soon.

Thanks @Ignacio Pulgar [Tecnofor]. Was freaking out over here.

 

Finally got a solution.


Is that a kind of bug when importing from the Bulk uploader ?

Sort of, we found that even we got error notice, we can still bulk upload data, therefore, we accept this.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

23,884 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you