Bulk copying one field to another field without script runner

Hi,

I'm running JIRA Cloud. I am changing the field type for a custom field. I've created the new field and want to copy all the old field values over to the new one.

However, I can't figure out a way to do this using the bulk edit UI. Is this not possible without the script runner plug-in (unavailable for JIRA Cloud).

I did have the idea to export to Excel, copy the values there, and then reimport to update the issues but I'm not sure how that will work out. Let me know if there's a better way to go.

Thanks!

2 answers

0 vote

No, there's no way to do this without addons (that you can't get on Cloud)

Your instincts about Excel are good though - when you export, make sure you include the issue key, because if you map it back to the key when importing, JIRA will treat the line as a change to the existing issue, not a new issue.

Actually, JIRA does not consider mapped JIRA Keys as updates. I have tried several different ways, and it always imports as new issues. These are the steps I created:

  1. Exported a single JIRA task to a csv file (fields Key, Summary and Old Custom Field). [Per documentation, Summary field is required in the exported file. However, contrary to the documentation, Summary field cannot be left NULL as the JIRA import process will complain about empty Summary fields].
  2. Edited file to remove 3 header lines, icon, and last footer line
  3. From the 'Issues' menu option, I next clicked 'Import Issues from CSV'
  4. Picked CSV file from Step 1
  5. Mapped each field as follows, and checked the 'Map' check box next to each field:
    - Key to Issue ID
    - Summary to Summary
    - Old Custom field to New Custom Field
  6. When I started the import, I found that (voila!) - the process had created a completely new issue (new JIRA key) - and left the old JIRA key untouched

This is badly documented - I wasted a lot of time trying to get this to work. Not just that, I had created so many issues in this manner that I ended up with a lot of junk JIRA issues that I eventually had to delete, thereby creating a significant 'hole' in my JIRA key sequence.

Yes, it does. But the reason it's not worked for you is that you've used the wrong method. In step 3, you say "import issues from CSV". You need to use the system import - see https://confluence.atlassian.com/jira/importing-data-from-csv-185729516.html

I just ran using the system import as well. There was one difference: the 'Next' button on the field mapping screen does not get enabled unless I map the Summary field. However, there was no difference in outcome once the import was done. It created a new Issue, did not update the existing one. It also complained that it couldn't find the custom field; not sure if this is causing the problem. 1. .CSV file has just this one entry: Key,Summary,SPR#_Old CDM-246,Create Deployment plan for the Patient Coverage release,9999 2. Log file says this: 2015-10-23 09:32:21,896 INFO - Importing issue: [externalId='CDM-246', summary='Create Deployment plan for the Patient Coverage release'] 2015-10-23 09:32:21,924 INFO - Custom field not found. Creating a new custom field for com.atlassian.jira.plugins.importer.external.beans.ExternalCustomField@19b57f[id=External issue ID,name=External issue ID,typeKey=com.atlassian.jira.plugin.system.customfieldtypes:textfield,searcherKey=com.atlassian.jira.plugin.system.customfieldtypes:textsearcher,valueMappingDefinition=<null>,valueSet=<null>]

Ok, I'm a bit stuck - I used CSV to update a dozen-ish issues from a spreadsheet yesterday afternoon - I was able to map "Key" to, well "Key" and it updated the fields on the existing issues. It looks to me like you've not mapped Key on to the issue key in Jira - note that the log says [externallId=...

Nic, thanks very much for the help. I was mapping the JIRA Key to "Issue ID" - should have mapped to "Issue Key". Amongst the hundreds of fields available, I didn't realize the two were different identifiers. Having an intelligent mapper (based on keyword) would have been nice... The import worked once I had the mapping right (I feel rather foolish about it now).

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,198 views 13 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot