Base URL for gadgets problem

Has anyone else upgraded from 6.4.x to 7.4.1 and received an health check error about "Base URL for gadgets"??  what does this mean?

my base URL is correct from what i gather.

 

https://jira.MYSERVERNAME.com/jira

the context path is set to '/jira' on server.xml.

 

anyone else experience this?

3 answers

0 vote

It's a bit more sensitive to proxy misconfiguration in JIRA 7 - what did you add for scheme, proxy and port on the end of the connector?

Here is the snippet from my configuration:
<Service name="Catalina">

        <Connector port="8080"

                   maxThreads="150"
                   minSpareThreads="25"
                   connectionTimeout="20000"
                   enableLookups="false"
                   maxHttpHeaderSize="8192"
                   protocol="HTTP/1.1"
                   useBodyEncodingForURI="true"
                   redirectPort="8443"
                   acceptCount="100"
                   disableUploadTimeout="true"
                   bindOnInit="false"/>

        <Connector port="28080"

                   maxThreads="150"
                   minSpareThreads="25"
                   connectionTimeout="20000"
                   scheme="https"
                   proxyName="jira.jirahost.com" | this matches the base URL on the jira administration page on my installation
                   proxyPort="443"
                   secure="true"
                   enableLookups="false"
                   maxHttpHeaderSize="8192"
                   protocol="HTTP/1.1"
                   useBodyEncodingForURI="true"
                   redirectPort="8443"
                   acceptCount="100"
                   disableUploadTimeout="true"/>

 should add, i inherited this from someone else.  im not too familiar with tomcat settings/proxys

Bother

scheme="https"
proxyName="jira.jirahost.com"
proxyPort="443"
secure="true"

Is the bit I was looking for and it looks fine.

Next question is what the proxy is set up to do - nginx, Apache or something else?

apache -  but i thought tomcast was the proxy?  this is where i'm confused.

 

Yeah, that confuses a lot of people - there's "Apache" the web-server, and "Tomcat", which is technically "Apache Tomcat", the application server.

Tomcat doesn't do proxying itself, not without a proxying application added to it (which you generally wouldn't do).

Most of us run Jira on a Tomcat located behind a web-server running as a proy.  I'm most familiar with Apache, but nginx, lighttpd and IIS all do it, and there are others.

When you're using a proxy, you need to tell Tomcat that a proxy is in use (which looks correct to me) and then tell the proxy what to actually proxy - that's the bit I'd want to check next.  For apache, there will be some lines saying "proxypass" in them.

in this file?
/etc/apache2/sites-available/default-ssl.conf

appears to just be a blank configured virtualhost configuraiton.

<IfModule mod_ssl.c>
        <VirtualHost _default_:443>

plus the usual lines for directory, etc.

what am i looking for? and where i guess is what im lost at

nevermind:

</Directory>

                <Location /jira>
                #       ProxyPreserveHost On
                        ProxyPass http://localhost:28080/jira
                        ProxyPassReverse http://localhost:28080/jira
                </Location>

 

does this help?

That's exactly the right section.  Mine is a little different in structure and says

    ProxyRequests Off
    ProxyPreserveHost On

    <Proxy *>
         Require all granted
    </Proxy>

    ProxyPass /jira http://192.168.1.144:8081/jira
    ProxyPassReverse /jira http://192.168.1.144:8081/jira

But I think your structure is an alternative way of saying the same thing.  But you're missing the first two lines I've got, and they do matter.

so make mine look like:

<FilesMatch "\.(cgi|shtml|phtml|php)$">
                                SSLOptions +StdEnvVars
                </FilesMatch>
                <Directory /usr/lib/cgi-bin>
                                SSLOptions +StdEnvVars
                </Directory>

                <Location /jira>

                        ProxyRequests Off
                        ProxyPreserveHost On
                        ProxyPass http://localhost:28080/jira
                        ProxyPassReverse http://localhost:28080/jira
                </Location>

<Proxy *>

   Require all granted

</Proxy>

Ended up being this fix:

"-Djsse.enableSNIExtension=false" setting to the Java arguments in <JIRA_install>/bin/setenv.sh

 

straight from atlassian. :)

Daniel,

 

Where exactly did you add that code?  i'm lookin in the setenv.sh, but don't know where to make the changes,

on my file, its near the top.   you can place it anywhere in the file i'd imagine. this is just a sane way of doing it.

#
#  Occasionally Atlassian Support may recommend that you set some specific JVM arguments.  You can use this variable below to do that.
#
JVM_SUPPORT_RECOMMENDED_ARGS="-Djsse.enableSNIExtension=false"

#
# The following 2 settings control the minimum and maximum given to the JIRA Java virtual machine.  In larger JIRA instances, the maximum amount will need to be increased.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

75 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you