Average time in status diagram only shows flat line

Hi all,

I am using Jira 5.0.7 and installed the Jira Charting Plugin 1.8. I added the custom field "time in status" with a global context (all projects all issue types). Also I have added it to (mostly) all screens. That was 3 weeks ago.

Now when I filter for issues I always get a single zero flat line as diagram. I made sure that there are actually issues in the results that have had different statuses and also there are some which have a resolution set (of course also both at the same time).

What am I missing?

Thanks

Tobi

3 answers

1 accepted

This widget could not be displayed.

Hi Tobi

This is a known BUG. Please use the following link for further details:

https://jira.atlassian.com/browse/JRA-29214

Since JIRA already have a valid field called "[CHART] Time in Status", you should not use/create this new custom field "time in status" to properly work with Averange Time In Status gadget.

Cheers,

Paulo Renato

Hmm many thanks for the hint! Are you sure this bug also applies to 5.0? The bug is only classified 5.1.1, 5.2-m01.

The problem is however that I created the field only because the chart plugin was complainig that it can't show charts because of a missing field. After googling I created the custom field.

I will try to remove it and see what it does.

Ok, just for reference. After removing the custom field I had to create a new one named "[CHART] Time in status" as implied by the linked bug report.

After that all worked fine.

SO I added the field, and called it "Time in Status" which as noted above broke the charts. But then I deleted it and got the "required field not found" errror. SO i created a new custom field called "[CHART] Time in status" with no search options, (tried free-text search too) and now all the charts either flat-line, or say no-data available.

NOTE: THis question says you also need to include it on screens that your issues use to make it work, https://answers.atlassian.com/questions/29452/how-do-i-get-the-average-time-in-status-chart-to-work so I included the field on all screens.



Do I need to reindex? Is there a service that populates the fields? Is all historical data gone?

Did your problem get resolved? I have a similar problem.

This widget could not be displayed.

I'm running JIRA 6.2.6 and Charting Plugin 1.23 and am still getting a flat line.  I have tried creating a "[CHART} Time in Status" field and re-indexed.  Still Flat line.

Hi, Did you find a solution to this problem? I have got the same problem.

This widget could not be displayed.

We had this issue after modifying workflows. We replaced "Resolved" status with a custom status. In the transition to that status, we did not include a post function to set Resolution to Done. The gadget only shows statistics for issues that are resolved. Since none of our issues had a value in the Resolution field, the gadget trend line was flat. To fix this, we had to bulk edit all issues that were in "Accepted" status following the guidance here: https://confluence.atlassian.com/jirakb/howto-bulk-edit-resolution-321857142.html

The lines showed accurate trends after we completed this bulk edit.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

555 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you