Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation rule is not working

Hi Team,

We've created an automation rule to send the notification on Microsoft Teams for a specific transition in workflow.

But when we checked in audit log we're getting the attached error. 

Can you please help us to know where we're missing here?

Thank you in advance. 

Regards,
NarendraAutomatin error.PNG

3 answers

0 votes
Jack Community Leader Dec 28, 2020 • edited

can you share the automation rule screenshot? also, outside of the automation, are you able to verify that the two apps are indeed connecting and working correctly?

Hi @Jack  please find the below screenshot of rule- Automation error2.PNGAlso, we're already using Jira and Teams integration for other transitions through webhook. Thank you for your reply. 

Hi @Narendra Kumar ,

Please check if you have followed the steps while configuring the automation rule for your project:

1. Go to project in which you want to setup automation rule.

2. Click on project settings

3. Click on Automation

4. Create new rule

5. Set the event on which you want the notification to be sent to MS teams

6. In action, Select Send Microsoft teams message

7. Go to MS teams and select channel in MS teams on which you want the notification

8. Click on ... of channel name 

9. Click on connectors and select incoming webhook and give it a name you want

10. Then you will get the webhook URL

11. Copy that URL and paste in Automation rule and fill all required information and activate it

12. Try triggering that event and check if there is notification in teams channel or not.

 

Hope that helps,

 

Thanks,

Raghav Gupta

Hi @Raghav Gupta  we're following exactly same as you've mentioned. Please have the screenshot of rule- Automation error2.PNG

0 votes

Hi,

It seems like there is perhaps some configuration issue with the way the incoming webhook is set up on the MS Teams side. That error message 'null or empty eventType' is the response your webhook request receives when trying to communicate with MS Teams.

I see there have been some similar issues raised in this community post. It seems some people had success by changing the MS Teams connector.

https://community.atlassian.com/t5/Bitbucket-questions/Jira-Automation-Microsoft-Teams-Message-with-Error-400/qaq-p/1341087

Another possibility is that perhaps a type of connector or version you are using requires a different payload than we are sending.  If this is the case you may need to raise a support request for us to dig into this further.

Cheers,
Brydie

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you