Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,652
Community Members
 
Community Events
176
Community Groups

Automation error related to "Linked issues" field

Hello! I'm receiving an automation error related to a rule I have. This rule creates a follow-up ticket after another ticket is marked as complete, based upon if a field is filled in. The audit log is indicating that a field might not be available on the target ticket, but that seems incorrect to me. It looks like the failure is related to linking the ticket to the trigger issue. I am able to manually link issues after the target ticket is created in the web interface, so perhaps linking issues needs to be implemented differently?

Audit log error information:

image.png

 

Automation rule step:

image.png

 

Verification that there is only the one "Linked issues" field and nothing obsolete

image.png

3 answers

I just had the same problem. The field should be added to the create screen.
The problem will be solved.

@Andrew Grossman I'm hitting the same issue.  Did you figure this one out?  Thanks.

Hi @Andrew Grossman and @Carson Holmes I have the same problem as you. I tried to add a link issue with a smart value and by selecting last created issue but both don't work. Did you find a solution?

0 votes

Hi @Andrew Grossman 

From your question description, I wonder: did you try to remove the set of Linked Issues field to confirm that is the cause, and not an error message...well, error?

I took a quick look and could not find this symptom on any open bugs in the Jira Cloud, Automation, or Code Barrel backlogs.

Next things to check:

  • When I have seen that error before, it was because of a duplicate field name (which you ruled out) or the field was not on the add/edit view.  That seems unlikely as you noted being able to manually link the issues.
  • I have seen other posts indicating occasional problems selecting the Create Issue action with the "Same project" option if this is a global/multi-project scope rule.  Perhaps try explicitly selecting the project name from the list.
  • Lastly, I wonder if there is some weird timing issue with issue create and linking.  One way to test that would be to remove the linking with the create and add a branch afterwards on Most recently created issue to perform the link.

Kind regards,
Bill

Suggest an answer

Log in or Sign up to answer