Attachment download issue

I am using JIRA REST API in our project . but while downloading if file name have special charector  its fail to authenticate below is the url

https://datacommunique.atlassian.net/secure/attachment/76424/file name

 

 

1 answer

0 votes

Hi Rahul,

I was running into something similar yesterday, however, the issue came down to the fact I was using a customized zsh.  When I switched back to bash the command worked as expected.

Another option would be to put quotes around the entire URL path and see if you get the results you're looking for as I had to do that or it would error:

curl -D- -O -u UN:PW -X GET "http://localhost:8080/secure/attachment/10011/hello rahul.txt"

 

Cheers,

Branden

Hi Branden McElveen,

I am using OAuth and as you said I have tried with double quotes its thows an exception. currently its working if there is no special charector but if special charectors comes in file name  its fail to authenticate

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 14, 2019 in Jira

Updates to jira.atlassian.com give you visibility into what's coming in Jira Server and Data Center

Hello, Community! My name is Gosia and I'm a Product Manager on Jira Server and Data Center here at Atlassian. Since 2002 when we launched our public issue tracker, jira.atlass...

745 views 1 15
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you