Am being asked login credentials repeatedly on JIRA-5.0

I see a really annoying behavior our jira instances.
Each time I do a request, it always asks me to login again with core -id & password,once I enter, it accepts & when I do a request then again it asks login credentials again. I have tried atleast more than 50 times to login.
I also tried deleting my cookies, rebooted my system, rebooted jira instance, but no use. This is really blocking us to meet our deadlines.
Even other users are experiencing similar problem.
Note: Am not talking about the account password validation of Admin users being asked

10 answers

1 accepted

I see this problem when I have 2 instances of the same product running on the same server (with different ports). Use a different browser for each instance. Close any tabs that are using any other instance.

I also had the exact same problem as experienced by several users in this thread (constantly being asked to re-enter login credentials).

I did notice one thing not noted here.. check the "Current User Sessions" page in JIRA.. it looks like the old sessions are active (even if using the bot killer plugin).

I also have Confluence and JIRA installed on the sameserver and Apache mod_proxy is used to handle port redirect.

The solution that worked for me was to add a CNAME RR to DNS so that the Confluence and JIRA URLs are unique & then these URLs were mapped in mod_proxy to the correct ports.

However, it was then necessary to go into Confluence General Configuration and change the Server Base URL to match what had been set up in DNS.

After that... no more barrage of requests to authenticate.

our scenario is a bit different. We have Jira, confluence, Crowd and Bamboo all on the same server.

The server has a 4 port NIC so we have dedicated IP addresses for Jira, Confluence,Crowd, Bamboo. We have apache redirecting from IP address/DNS to the machine name port

eg,

<VirtualHost 10.243.2.193:80>
ServerName jira.onlifehealth.com
Redirect / https://jira.onlifehealth.com/
</VirtualHost>
<VirtualHost
10.243.3.9:80>
ServerName crucible.onlifehealth.com
Redirect / https://crucible.onlifehealth.com/
</VirtualHost>
<VirtualHost
10.243.3.8:80>
ServerName bamboo.onlifehealth.com
Redirect / https://bamboo.onlifehealth.com/
</VirtualHost>
<VirtualHost
10.243.3.10:80>
ServerName confluence.onlifehealth.com
Redirect / https://confluence.onlifehealth.com/
</VirtualHost
>

also

NameVirtualHost 10.243.2.193:443

<VirtualHost 10.243.2.193:443>
ServerName jira.onlifehealth.com

ProxyRequests Off
ProxyPreserveHost On
<Proxy *>
Order deny,allow
Allow from all
</Proxy>

SSLEngine On
SSLCertificateFile "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/conf/ssl/jira.cert"
SSLCertificateKeyFile "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/conf/ssl/jira.key"

ProxyPass / ajp://<machinename>:8009/
ProxyPassReverse / ajp://<machinename>:8009/
<Location />

Order allow,deny
Allow from all

</Location>
</VirtualHost>

and similar for Confluence

In the specific tomcat apps we also denote the same ip addresses in the connection

ie, Jira server.xml

<Service name="Catalina">

<Connector port="8085"
address="10.243.2.193"
maxThreads="150"
minSpareThreads="25"
maxSpareThreads="75"
connectionTimeout="20000"

enableLookups="false"
maxHttpHeaderSize="8192"
protocol="HTTP/1.1"
useBodyEncodingForURI="true"
redirectPort="443"
acceptCount="100"
disableUploadTimeout="true"/>

//and

<Connector address="10.243.2.193" port="8009" redirectPort="8443" enableLookups="false" protocol="AJP/1.3" URIEncoding="UTF-8"/>

Some people have the problem of having to login frequently more than others.

Any ideas or suggestions?

I have the same issue !

did you find any solution?

0 vote

It sounds like your server and/or client are forgetting the session somehow.

Could you tell us what authentication you are using? Jira off-the-shelf, Crowd, LDAP, something else?

Also, have you tried a different browser? (I doubt it's the browser, but if they behave differently, it could tell us something). And do your logs say much? Any interesting warnings/errors related to users logging in? You say other users are having the problem - is it universal (all your users) or a consistent set of them, or a random set?

Nic, Thanks a lot for always being of great help.

Problem is seen on Chrome & Firefox as well.

Authentication used is JIRA Delegated Authentication Directory

Logs show nothing for this behaviour, dont see log being updated for this prob.

Its a test instance, so only a couple of developers use it as of now and so I cannot say anything about the consistent/random group of users facing this prob.

Do i need to do some kind of clean up? If so, then what should I do?

I changed my system also, still problem seen.

Hmm, well, that all sounds consistent to me, it's almost certainly something in the sessions going wrong. I'm afraid I'm out of my depth here - I've configured LDAP connectors, simply by following the docs to the letter, and I've always had it work as soon as I'd got all the parameters right, so I'm really not sure.

I would try to check the LDAP settings are 100% matched - i.e. go over the doc at https://confluence.atlassian.com/display/JIRA/Connecting+to+an+Internal+Directory+with+LDAP+Authentication and make sure everything is a perfect match - all the CN, DC and so-on are exactly what your LDAP server is expecting (even to the case of the data, although I really don't remember if LDAP is ever case-sensitive)

This is a longshot. What is your session timeout set to? Do you have cookies enabled to be able to record your session?

https://confluence.atlassian.com/display/JIRA050/Changing+the+default+session+timeout

I have this problem on specific testing instance running from SDK by atlas-run using Firefox12. When I access the instance with IE9, login works.

I also see prob in IE 8.0

Do u have any other Atlassian instance installed on your environment? Could you please try to add a unique context path to your JIRA instance and see if it helps.

I checked my web.xml, I see as below

[~ WEB-INF]# grep "session-timeout" web.xml

<session-timeout>300</session-timeout>

manytimes, it logs us off even for less than 5 sec activity gap.

Everyone..

Just wanted to let you know that I see this prob only from today afternoon, these instances were working normally earlier with even more users since installed i.e a month ago.

Thanks

Nazia

We are having the same issue. We have Jira and Confluence installed on the same server and use Apache Mod_proxy / Reverse proxy to the port for Jira / Confluence. We also use Crowd (on the same server as well) for SSO / LDAP active directory authentication.

Not sure what to try to fix this issue. We have increased the time out to a 1000.

We have authorization caching set in crowd and dont have secure cookie set. In the session config in crowd we had set at 60 and have database cache selected.

I have confluence confluence and jira installed on same server; but different tomcat instances. I am using war versions of both the products.

* Jira asks for credentials repeatedly but confluence is working fine.

* The problem occurs in Firefox only; I am using FF 19.0. In chrome it is working fine.

Are you having a context set for each or just that the ports are different? if just ports the cookies will get overwritten - https://confluence.atlassian.com/display/CONFKB/Logging+into+Another+Atlassian+Application+Logs+Me+Out+of+Confluence

Confluence and Jira are installed on the same computer

Then read the above article and add a context for each of them in server.xml

I am having the same problem but it looks liek Renjith has nailed it. It seems like sessions are being reset or "forgotten" by the browser.

I have confluence and JIRA installed on the same machine and they both have the default root context. When I can see that there are many un-used sessions.

Changing the context is tricky because you need to go back and update all the application and authentication links.

I figure it is a common case where people install multiple atlassain apps on the same server. Atlassain should really give their default installs different contexts so this never happens.

I have seen this on the captcha screen on Firefox 26, it will loop and never accept the correct captcha. I can switch over to Safari, log in just fine ,then back to Firefox and refresh and I'm logged in.

Your issue seems to be caused by corrupted browser cookies.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

690 views 6 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you