After updating Ubuntu to 16.04, "Cannot add user, all the user directories are read-only."

Yesterday, I unsuspectingly updated Ubuntu to 16.04 without realizing that it would allow me only to install MySQL 5.7, unsupported by JIRA.  So, after downgrading to MySQL 5.6, I was unable to get past the Administrator User addition stage; I always get "Cannot add user, all the user directories are read only".  I have tried 2 full reinstalls of JIRA and nothing has worked, including deleting my jiradb database and jiradbuser multiple times.  Tomorrow, I will wipe completely MySQL and see if I can re-add only my previous jiradb to the new database.  Does anyone have any clues what I can do next?  I have deleted all folders inside /opt/atlassian/JIRA and deleted my home directory.  Why doesn't a full reinstall work?  Did MySQL 5.7 break my database so it no longer works with version 5.6?  When will MySQL 5.7 support come to JIRA?  Should I just go back to Ubuntu 14.04??

1 answer

1 accepted

Of course, the simplest solution was the one that worked; restarting.  After restarting (and returning with a bit more patience today), I had to fix ulimit on my MySQL installation, but I was able to connect.  I think finished restoring my system from an old database and home folder by going through the steps from https://answers.atlassian.com/questions/195807

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

241 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you