Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,076
Community Members
 
Community Events
176
Community Groups

Add existing test to test coverage in Story

Hi,

System: Jira Xray

Problem: Cannot link existing test to the entity "Test Coverage". We've created a lot of tests in Xray, and linked them manually to stories (using "Linked issues"). Now we've defined Story to be test covered in the settings (using this instruction: https://confluence.xpand-it.com/display/XRAYCLOUD/Project+Settings%3A+Test+Coverage), but when I create reports to see Test Coverage for a defined Test Plan it seems to be none. 

Question: How can I link existing tests to the entity "Test Coverage" to get my reports / Dashboards to be correct?

Capture.PNG

2 answers

The other way to handle this issue is that if you have already created the test ticket, and wants to cover for a specific story, then just go to the story and in link issues user "Is tested by" and add the test ticket number as a result when you refresh you will see that the story is covered

0 votes

Hi Marte, 

Can you please verify if in Jira Administration >> "Jira Settings", "Field Configurations", if the field "Linked Issues" is hidden? It's necessary for Xray that this field remains visible.

If this not solves the problem, please contact us through our Service Desk.

 

Best Regards,

Team Xray

Thanks for contacting me. Unfortunately it's not easy for the Project to get the SEN-number, so I wasn't able to send a request through your service desk. 

Your suggested solution did not work for us, the field is visible.

More information to the problem: The test-coverage are working as expected on tasks that was being linked to tests after the setting was done. 

Hi Marte, 

Here's a guide to help you find your SEN: https://confluence.atlassian.com/support/how-to-find-your-support-entitlement-number-sen-229840018.html

Reach out to our support team and they'll guide you through the process to solve your issue.

Best Regards,

Team Xray

Has this been resolved?  I am having the same issue and needing to be able to use existing tests on a story and would like to not have to create a duplicate test case.  

Hi, yes. You must link the existing Test to the issue by using "Tests", and search up the issue. It's better to do it from the Test-issue type, not from the Story / Bug / Epic. You will then see that its covered from the Story / Bug / Epic the test is linked up to.Linked issue from test-issue.JPG

Like # people like this

Great!  Thank you for your response.  

Like # people like this

Hi Marte,

I am also facing same issue. Can you pls explain how did it worked for you with flow and some screenshot?

Hi! If you see my screenshot its from a task. Open your test-issue type instead, and choose "Linke Issue" and then choose "Tests.." and find you task / story. It should be linked correctly. 

Hi Marte,

 

I have created xray test issue type only. But still it is not coming under Test Coverage.

Screenshot below for your reference.

 

I want TAR-21 to come under test coverage. Pls help

Untitled.png

You must change the relation to "Tests", its currently set to "is blocked by". 

1. Open TAR-21

2. Change the linked value from "is blocked by" to "tests", and select TAR-20

Please let me know if this helps.

Marte

Perfect... It is showing properly now.

Thank you Marte. :) 

Regards,

Atheeq

Like marte-skrunes.ellingsen likes this

@Marte Skrunes Ellingsen I tried your method but I still see my story is uncovered despite associating test as tests. Please help:test coverage.png

@Asher Sinha Update your linked issue on your bug so it is 'tested by' PLUS-6135. This should reverse the direction of the relationship and show the bug as 'covered'. From the screenshot, it's opposite way. 

Like Asher Sinha likes this

Suggest an answer

Log in or Sign up to answer