Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Add a label from an Epic - Automation

Hello community! 


I have reviewed some posts from here but nothing works :/


I want to automate that, when an issue is updated, review its Epic Link and if it matches RTB or Run the business in its name, then add the "RTB" label on the updated issue.

I have created this automation, but when I run it, the Audit log indicates that no actions are performed. 


Any idea about what's wrong? RTBQuestion.png

1 answer

1 accepted

0 votes
Answer accepted
Fernando Eugênio da Silva
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
May 23, 2023

@Luis Eder Rivera , Welcome to the Atlassian Community!

You are using the wrong JQL for this case.

The JQL you are using would only work if you were making a condition to read the updated issue itself.

Something like:
For Current Issue > IF > "Epic Link" = XXXXX

As you are using a related issue to fetch the associated Epic, in JQL you only need to put the Epic key. Something like this: key = EPIC_KEY

Like this:Screenshot_111.png

The key needs to be the 'Epic Key'.

Hope this helps



Hi Fernando, this worked perfectly! Thanks for your guidance! 

Suggest an answer

Log in or Sign up to answer