Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Activity Stream Jira emty!!!

Hello to all,

before 2 days we are working on jira on the company. We using as http protocol. After certification install and bind to 443 we use it ass https://My problem is that after that after http to https bind activity stream is empty nothing at all. Even error msg!

The dasboard that we are using is custom and we have also activity stream as my description.

Anybody knows what im lookinf for ?

P.S We use it with IIS

2 answers

Hi @Arkadios Chalikiopoulos ! How are you doing?

You should check the base url in your Jira administration section and also the proxyName and proxyPort properties in your connector that is in your conf/server.xml file inside your installation directory.

Base url should be set to the url that users are using to access Jira through your IIS server. The property proxyName should have your IIS server name and proxyPort should have 443.

Check this and let us know if it works.

Hope this helps!

Hello and thank you.but i think i have do it that , please take a look on my conf

<Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"
maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"
maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"
acceptCount="100" disableUploadTimeout="true" bindOnInit="false" scheme="https" proxyName="mydomain.com" proxyPort="443"/>

 

this is my conf with not real domain name....i change it...So what exaclty the error if i have!

Hi @Arkadios Chalikiopoulos !

Your server.xml file looks good. What value is set in Jira Base URL?

https://<your-iis-server-name> ?

Hello and thank you.

Yes as you write on your message

 

Base Url JIRA

https://<mydomain.com>

Nothing changes from my last settings on 443 ---> iis

but the only thing on dashboard that stiloo dont show data is the activity stream

Basic shows nothing even an error. Only white board!!!

Hi @Arkadios Chalikiopoulos !

Take a look at this bug: https://jira.atlassian.com/browse/JRASERVER-64917

It has been fixed now, but maybe your version is still affected.

The workaround is to execute a Power Shell command to change a value in Windows Registry.

It is worth a try!

Hello and thank you.

Basic my Jira verion Software 8.4.2. So i dont think its some bug!

But i say just for reply and check all that this is happen after install certification and the bind on 443.

Everything works fine except Activity Stream!!!

Thats what say it is very strange! and i dont know that to do about!!

Before on http everything is normal....Activity!

 

Jira on IIS service

Hi @Arkadios Chalikiopoulos !

I have read in the comments of the issue that people using some of the latest 7.X versions still had problems.

Even tough you are using 8.X, maybe it would be a good thing to try the workaround, as it does not seem to be a dangerous thing to do.

Ok i understand what you say. Maybe give a shoot but its a little compllicated that because also Server Is HyperV and its online all the time, and to be true i have a little worrie about if something goes wrong with registry!

 

Any else you believe to check except your previous answer ?

 

Arkadios

Unfortunately, the only things I could think of are server.xml and Base URL, that I mentioned before.

Take a look at the details of the bug. Using the Developer Tools of Chrome or Firefox, check whether the URL for your activity stream has more more than 260 chars in the section they mention.

If it has, then you apply the workaround. If it does not, maybe it is related to other things.

Do you have a staging environment to test it before applying to production?

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you