It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

426 Error Upgrade Required

When performing a wget to download Jira or Confluence Server recently I've been getting a 426 Upgrade Required error response. There's not much in the response that tells me how to modify the request, so I'm not sure how to download directly to a server anymore. (Downloading through the browser still works fine.)

e.g.

wget https://www.atlassian.com/software/confluence/downloads/binary/atlassian-confluence-6.13.8.tar.gz

Does anybody know how to modify the command to allow it to work or at least can explain the limitation? Does everyone get this response?

4 answers

I suspect it's related to TLS versions. I can only connect with TLS1.2 and so perhaps the version of wget you/I'm using doesn't support it.

Anyway, I tried with curl and that downloaded fine e.g.

curl -L -O https://www.atlassian.com/software/jira/downloads/binary/atlassian-jira-software-8.4.1-x64.bin
0 votes
Mirek Community Leader Aug 31, 2019

Hi @MikeyS 

Try with -O parameter and optionaly --no-check-certificate

wget --no-check-certificate -O atlassian-confluence-6.13.8.tar.gz https://www.atlassian.com/software/confluence/downloads/binary/atlassian-confluence-6.13.8.tar.gz

I'm having the same issue MikeyS - did you have any luck resolving this?

Nope, not yet.

having the same issue too at the moment.

Same error for me today.  I've downloaded on a Windows machine via the website and copied over to my Linux server as a workaround!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

The add-in you’ve been waiting for: Jira Cloud for Excel 🙌

Introducing Jira Cloud for Excel Here at the product integrations team at Atlassian, we are thrilled to announce the new Jira Cloud for Excel add-in! This add-in lets you export Jira data directly ...

864 views 6 24
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you