401 Unauthroized error when running curl GET API command on my localhost

Hello all, I'm trying to run a simple GET request through the JIRA API. However, every time I run the code, I am getting a 401 Unauthorized error, despite using my admin username password.

What am I missing in my snippet in order to give authorization?

Here is the snipped of what I'm using:

curl -D- -u user:userPassword -X GET -H "Content-Type: application/json" "http://localhost:8080/rest/api/2/user?username=selectedUser

1 answer

1 accepted

Accepted Answer
0 votes

Everything looks good. There is an extra double quotes before your url but I am guessing that is a typo.

Make sure your username and password is correct. Can't think of any other issues.

That fixed it, thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

23,922 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you