Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Automation for Jira - Clone issue and set fixVersion in original issue and clone.

Sergei Gridnevskii
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Nov 15, 2021

We have two products that are quite similar but still need to be tested separately. When we have a task or a bug developer adds both product versions to Fix Versions field in Jira. However QA needs to test both versions separately and they asked me to clone the issue when it moves to Ready for Test step.


So I created a special rule for Automation for Jira. It took me some time to figure out how to make it working, I hope it will save your time if you need to do the same.

1. The field {{issue.fixVersions}} is a list. If you just use {{}} it returns all versions merged without separator. I use this string to check if both products are in this issue: 

IF {{}} contains "Prod1" AND {{}} contains "Prod2"


2. I clone issue and Choose field to set Fix Versions. For value I use {{}}

I tried More options and tried to "set" and "remove", but nothing worked - no errors, no results.

3. I link issue and most recently created issue 


4. I edit original issue and this time More options work fine

"update": {
"set": [{"name": "{{}}"}]




Log in or Sign up to comment