Unsubscribe / Subscription expired while having Okta provisioning

Problem

Once an Unsubscribe/Subscription expiration is triggered while having Okta provisioning active, the SCIM virtual directory will stop to sync the users/groups from Okta to Atlassian, and these groups will become normal local groups at the instance level (https://<example>.atlassian.net). After re-subscribing a new external directory must be created. See Configure user provisioning with Okta for more details.

Diagnosis

  • The unsubscribe process is triggered or the subscription expires

  • User provisioning sync stops

  • Users and groups become local Atlassian objects, i.e. they are modifiable

Cause

The directory used for user provisioning is removed and in order to avoid the loss of the synced groups, groups become local Atlassian objects.

Workaround

Since Pushing a group from your IdP that has the same name as a group in your organization is an unsupported feature you can rename the group to sync again ( remember to remove the old group after ), if it’s needed to push the group with the same name it will be required to delete the local groups from all instances they’re related to and group push them from Okta to Atlassian again ( a heads-up here, once deleting you delete the Group from Jira you'll remove the permissions schemes and project roles related to this group, those will need to be re-added later ). Otherwise the sync will try to push the groups from the IdP to Atlassian, but since there are already groups with the same name in the Cloud site, no change will occur and the groups won’t be provisioned. In order to provision the groups once more the step-by-step process you can see below:

Re-activating Group Provisioning

 

1. Select your local group/s under Group menu at the admin's page (https://<example>.atlassian.net/admin):

 Screen Shot 2019-02-12 at 16.50.34.png

 

2. Use the Delete group option:

 

Screen Shot 2019-02-12 at 16.47.37.png 

3. Proceed with Delete group:

 

Screen Shot 2019-02-12 at 16.47.52.png 

 

4. In Push Groups section under your Okta app, use the Push now option to re-create the group/s:

 

Screen Shot 2019-02-07 at 13.07.29.png

 

Concluding those steps the groups will be re-added to the application and you'll have to apply the permissions scheme and project roles that are desired to the groups.

1 comment

João Nunes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 22, 2019

Thanks for sharing, Matheus!

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