Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,455,400
Community Members
 
Community Events
175
Community Groups

Why Epic Link doesn't appear on issue cards in Board ?

We have recently migrated our Jira software to Jira Work Management (business project). We have a lot of issues on the board and at the beginning, when I set up on "Customize Cards" to show Epic link on the board, it was there. But right now, even when I have Epic link checked off, it doesn't show epic link on the board. Is this some kind of bug or is it because we have a lot of issues on the board? Seems like a lot issues shouldn't be a problem, right? 

4 answers

1 accepted

2 votes
Answer accepted

Hi everyone,

Atlassian developers confirmed that this is a new bug, so they created a bug ticket for this, but we don't know when this will be solved. They advised me to add myself as a watcher so I will get updates when something happens. 

 

Here it is: https://jira.atlassian.com/browse/JWMCLOUD-397 

Seems like this is already a duplicate of this issue https://jira.atlassian.com/browse/JWMCLOUD-395 

Like # people like this

Howdy Y'all,

I can confirm that the Bug https://jira.atlassian.com/browse/JWMCLOUD-395  is the one that you want to keep an eye on for this issue, and the initial bug mentioned was closed out as a duplicate as it was created a few days later.

While we do not have an ETA as to when this will get fixed it is flagged for the short-term backlog and a quick fix as a medium-impact bug.

More details on the bug-fix policy can be seen here:

Regards,
Earl

Like Jack Brickey likes this

@Nikola Nemjóová could you give an update on this issue if you have one? I'm also having the same issue. Would be great if you could share the solution here. 

 

thanks in advance!

Jack Brickey Community Leader Jan 24, 2023

Hi @Laura Boessenkool , interesting that some are experiencing the same issue while others are not. Can you share details of your scenario. Does the Epic appear under and scenario? If so, when/how? Are you using Group by? Which fields are configured to display on the cards?

Hi @Jack Brickey

 

I’m using a kanban, company managed project (business).

I've selected group by status and the epic link is box in on

Epics link are coming from another board (called offertes). 

The epic link in showing on the task detail (picture 3) but not showing on the overview page with columns.

 

I want to have the epic links shown in the overview, so people can see with which epic the task is connected. 

 

 

Scherm­afbeelding 2023-01-24 om 13.48.02.pngScherm­afbeelding 2023-01-24 om 13.48.31.pngScherm­afbeelding 2023-01-24 om 13.48.54.png

Jack Brickey Community Leader Jan 24, 2023

Thanks @Laura Boessenkool

So I am able to recreate and actually I cannot get Epic link to display under any circumstance now. I have to wonder if my earlier testing was flawed. :-(

I think this needs to be raised with Atlassian support.

Okay. @Nikola Nemjóová raised a support question. So I suggest we'll wait for her answer, right? 

Jack Brickey Community Leader Jan 24, 2023

yes but I notified colleagues.

hi @Nikola Nemjóová ,

I updated this...i think my earlier testing may have been flawed. I cannot get the Epic link to display at all. :-(

 

Have you found anything new on this? How was experimenting with us a bit yesterday and can you do a bit more today. I was unable to reproduce this in my instance but I suspect there are quite a number of differences between your set up and mine. One thing I see is that you have a lot of fields checked toy show up on the cards. I have no idea if this may be the cause but wondering if you could uncheck everything except epic link.

 

tried this, doesn't make a difference.

0 votes
Trudy Claspill Community Leader Jan 18, 2023

Hello @Nikola Nemjóová 

Welcome to the Atlassian community!

Is your project a Team Managed project or a Company Managed project? That information is shown at the bottom of the navigation pane on the left.

How many issues do you have on the board? A Work Management board can display up to 1000 issues. 

Can you provide a screen image example of a card that you think should show the Epic information but does not? Can you show the details of that issue to show that it is indeed assigned as a Child Issue of an Epic?

Is the Epic itself displayed on the board?

Our project is Company Managed Project.

On board, there are around 220 issues. 

Almost every issue has an Epic. - Our Category is basically same as Epic, because we wanted to be able to filter by epics (but that's not possible). But I would also like to see the epic on the board because Category doesn't show it labeled by colors, and Epic does. 

Epic itself is displayed on the board (all are).

Screenshot 2023-01-19 at 9.24.24 AM.pngScreenshot 2023-01-19 at 9.27.20 AM.png

I have exact the same problem. First it was there, now its gone. 

customize cards- show epic link is on but nothing happens. 

 

Hope we can solve this! :) 

Exactly! Maybe that's a bug since they implemented "Group by" on Board? Seems like it started happening when that new feature appeared, but I might be wrong. 

Like Laura Boessenkool likes this

"Group by" feature - I think It's a new feature introduced just a few days back. It was mentioned here: https://www.youtube.com/watch?v=_eoKRdAt79U&ab_channel=Atlassian 

We are on a company managed business project, and I'm seeing this Group by option on board. -> It appeared only few days ago. 

 

Screenshot 2023-01-19 at 5.06.16 PM.pngScreenshot 2023-01-19 at 5.06.42 PM.png

Trudy Claspill Community Leader Jan 19, 2023

Hello @Nikola Nemjóová 

I don't see the Group By option in the Business projects of any of the Jira Cloud systems to which I have access. I'm reaching out to other Community Leaders to see if they are familiar with that feature.

Like Nikola Nemjóová likes this
Trudy Claspill Community Leader Jan 19, 2023

Yes, another Community Leader was able to direct me to the blog post for weekly changes.

https://confluence.atlassian.com/cloud/blog/2023/01/atlassian-cloud-changes-jan-9-to-jan-16-2023

Some of those leaders who see that Group By functionality in their systems are experimenting to see if they can reproduce your issue.

Trudy Claspill Community Leader Jan 19, 2023

Have you tried unchecking the option in the Group By to see if that makes a difference?

Yes, I did. It doesn't make a difference. When I uncheck the "category" it works as it should, but when I uncheck the Epic Link, nothing, and when I check it again, nothing.

Trudy Claspill Community Leader Jan 19, 2023

I'm not sure what you mean by "When I uncheck the "category" it works as it should,".

Does that mean when you don't use the Group By option then the Epic Link field does display on the card (when it is checked in the Card Customization options)?

No, Epic link doesn't appear in any situation.

What I mean by  "When I uncheck the "category" (on the Customize cards). it works as it should," - the category doesn't show up on the card on the board. When I check it, it appears there. But with Epic link, it doesn't work as it should. 

Trudy Claspill Community Leader Jan 19, 2023

Ok. What I was asking you to try was to uncheck the options in the Group By feature. If you don't group the issues, does the Epic Link display in the cards?

Well they have to be grouped by something (default is by Status) - Group By function is grouping issues to the columns. So you cannot really ungroup, just "clear" grouping which will set it to default - group by status. 

But even when I group by anything else, or clear the group by, it still doesn't show epic link. It doesn't show epic link at all, I tried everything. 

Trudy Claspill Community Leader Jan 19, 2023

Hm, I am at a loss. Other community leaders that have access to the Group By function have not been able to reproduce the issue so far.

If you are working on a paid subscription to the Jira product I advise you to have a Jira Administrator open a support case directly with Atlassian to do additional investigation.

https://support.atlassian.com/contact/#/

Will do, thank you! :) 

@Nikola Nemjóovádid this get resolved in some way? I'm having exactly the same problem AFAICT.

Like Laura Boessenkool likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events