Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Paste URL is broken in create issue page using Forms in JWM

I know that I could've raised this with Atlassian Technical Support, but their support form is also not working for some reason (tried it too many times over the course of last two days with no success).

It seems that paste URL (smart links feature) is somehow broken in issue create screen using Forms in JWM. I can reproduce this consistently, here's Loom video in case anyone is interested - https://www.loom.com/share/e6f87ec2de7040c2b74047960a319c1b

This seems to be a recent thing, because this was working in September.

Steps to reproduce

  1. create new Form in JWM > Project settings > Forms (make sure Description field is included in the form)
  2. preview the Form page (e.g. https://YOUR-SITE.atlassian.net/jira/core/projects/PROJECT/form/18)
  3. copy any URL into a clipboard
  4. in the Form page, click Description and paste the URL

Expected result
URL is transformed into a card -or- URL shown as-is

Actual result
URL disappears completely (as if nothing was entered)

Looking deeper into this I can see that rich-text field (Description in issue create using Forms in JWM) is not rendering <span class=card> tag. Compared this to other places where this feature works fine (new issue create in Jira, new request create in JSM).

Screen Shot 2022-10-18 at 15.42.11.pngScreen Shot 2022-10-18 at 15.42.58.png

Then compared the sources that are loaded for this page and noticed that the following asset is missing in source code (while it is present in the issue create dialogue using Jira > Create)
https://jira-frontend-static.prod.public.atl-paas.net/assets-brotli/@atlaskit-internal_renderer-node_InlineCard.1f44d66eee43a1b73561.8.js 

Did anyone else have experienced this?

1 answer

HI,

I have the same problem since Forms exists.

Issue seems occuring on Jira, Confluence or Google drive links.
A link to a website is OK

So maybe the issue somewhere during the link preview step.

I don't have this behavior when I create an issue directly in JWM.


Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events