Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

I can't find the security level field

Dimby Andriamanga October 18, 2022

Hi!

I look at the list of custom fields, I can't find the security level field.

So, I can't display the security level field in my issue.

Can you help me?

Dimby

3 answers

1 accepted

0 votes
Answer accepted
Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 18, 2022

The security level is not a custom field, and is (slightly annoyingly) referred to as "Level" or "Security level" in different places.  You'll need to look for both names.

I suspect what might be missing here is a full understanding of the rules of display.  To get the field seen on an issue, it's a bit more complex than other fields.  You need to have the following settings:

  • Level is not hidden in the field configuration
  • Level is on the create/edit screen
  • You have the permission to set a security level
  • You are part of one or more of the security levels.  If you are not included in any, you can't set any levels, so the field disappears (no point offering a field you can't put data into)

Can you check through all of those?

Dimby Andriamanga October 18, 2022

Hi Nic!

- Level is not hidden in the field configuration (see 1st screenshot)

- I have permission to set security level (see 2nd screenshot)

- I am group administrator

- But Level is not on the create/edit screen. Field is nowhereCapture d’écran 2022-10-19 085413.pngCapture d’écran 2022-10-19 085808.pngimage_2022-10-19_091104651.png (3rd screenshot)

Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 19, 2022

The issue layout in your last screenshot does not show security level because it is a system field that always appears if it is in use.

The first one is what matters - it has to be on screen, and you've got it set up correctly there.

You need to check the security scheme to see if you are included in a security level.  Compare your account to the group and role shown in your second screenshot (being a group admin does not mean "can do everything", it means you have some admin rights.  The security levels, like permissions, only look at the rules set for them, they don't automatically include admins)

Like James Seabrook likes this
Dimby Andriamanga October 20, 2022

Phew!
Finally, the icon appeared. Thanks to all of you

Who can change the security level in the issue?

Like John Funk likes this
Nic Brough -Adaptavist-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 20, 2022

Excellent news!

The people who can change the security level are any account that has the "set security" permission you've shown in your screenshots.

They also need to be included in the security level they are trying to set.

If, for example, we had a security scheme like

  • Top Secret: Nic and Alice
  • Secret: Nic and Bob

Then I could set the level to "none", "top secret" and "secret".  Bob could only select "none" and "secret", Alice could only set it to "none" or "Top secret", and Charlie would not be offered the field because they're not in any level.

Like Larry McClelland likes this
Dimby Andriamanga October 21, 2022

your explanation is very clear.

Thx Nic

0 votes
Rilwan Ahmed
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 18, 2022

Hi @Dimby Andriamanga ,

Welcome to the community !!

Security level is not a custom field. You need to set it first in your project. (Project settings --> Issues --> Security)

Please note: 

  1. You need to be a Jira Cloud admin to configure issue-level security.
  2. Before anyone can set issue-level security, you first need to grant relevant users and groups the Set Issue Security project permission.
  3. The security level lock icon will only appear if there's a security scheme set for the project. Only users with permission can set the issue security level.
Dimby Andriamanga October 18, 2022

I have security scheme in my project. There is not yet lock icon!

Rilwan Ahmed
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 19, 2022

Hi @Dimby Andriamanga 

What type of project are you checking in ? 

The main way to tell whether you’re in team  or company managed  project is to look at the bottom of the left menu in your project. There, you’ll see either:

  • You're in a company-managed project

  • You're in a team-managed project

Dimby Andriamanga October 20, 2022

Hi Rilwan,

Thanks to all of you, the icon appeared.

Who can change the level?

Like John Funk likes this
Rilwan Ahmed
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 20, 2022

Hi @Dimby Andriamanga ,

  1. You need to be a Jira Cloud admin to configure issue-level security.
  2. Before anyone can set issue-level security, you first need to grant relevant users and groups the Set Issue Security project permission.
paul_creedy April 4, 2023

Sorry to jump on this thread but how did you get it to appear?

As far as I can tell I've done everything and I have the exact same problem. Can you remember what you did you get the security level to appear on the issues?

0 votes
John Funk
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 18, 2022

Hi Dimby,

It is not a custom field, it is a system field. 

Go to Settings > Issues > Issue Security Schemes to create the Security Scheme and then the Levels. It is the Level that you will apply to the issues. 

Dimby Andriamanga October 18, 2022

I have already configured a security scheme in my project.

What else should I do?

Capture d’écran 2022-10-18 142337.png

John Funk
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
October 19, 2022

It looks like you have a Default Security Level for all new issues, which is good. However, if you created the Issue Security Scheme after issues were already created, it would not add them to those issues. I suggest you create a filter/query to see those issues:

project = ABC and Level is empty

Then do a Bulk change on those issues to update the Security Level through an edit. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events