Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,485
Community Members
 
Community Events
176
Community Groups

Enable REST API for User and Org

Hi everyone!

I'm very new to this, so apologies if I'm missing something big here.  From what I can tell, REST APIs are supposed to be enabled by default with Jira, yet I'm trying to use this plugin and am getting the below error message:

"The REST API is not enabled for this User or Organization. This integration will not work unless the the REST API is enabled. Please contact your CRM administrator."

I'm the admin, but I'm looking through REST API docs and I'm not sure how to start.  Even if you're not familiar with the plugin, maybe you know how to enable REST APIs for the org/user or why I might not be detected as such?

Thanks so much!

1 answer

1 accepted

0 votes
Answer accepted

Hi @Chelsea.Learned ,

You're right, Jira's REST API is enabled by default, I think what you are missing here is to set the connection for the CRM integration and that is what the error message means. To set it, follow the "Set up a connection to your CRM" part in the CRM for Jira Cloud documentation.

Hi @Zsuzsa Galicza _Midori_ 

 That's when I get the error, actually.

1. I installed the app
2. Clicked Project Settings (That's the only place I see the option for CRM Integration)
Selected Apps> CRM integration
3. I see the app settings for my chosen app and it asks me to click my CRM, login, and click continue.
4. I enter my credentials and click continue, then get the error.

@Chelsea.Learned Is it possible that the REST API is not enabled for your CRM then? Your error message says to contact your CRM administrator so the restriction might be on that side.

Sadly I'm not familiar with the app and don't use CRM so there's only so much that I can try out in my instance. But you can try a simple request for your Jira REST API to see that it works:

{yourJiraUrl}/rest/api/3/issue/{issueKey} where yourJiraUrl is the base URL of your Jira Cloud (e.g. my-jira.atlassian.net) and issueKey is an existing issue's key, like TEST-1. Just put it in the address bar of the same browser where you are logged in to your Jira instance.

Thanks, @Zsuzsa Galicza _Midori_ !

 

I think that must be it.  I just tried what you suggested and got a long output on the Jira side.  I'm going to see if I can enable the REST API on the CRM side and see if that does it...

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events