Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,083
Community Members
 
Community Events
176
Community Groups

Bug - Assignee field not working properly in Work Management

Edited

Initial post

The Assignee field only shows all users when creating a new Issue (task) in Work Management. Once is it created if I want to re-assign the task the Assignee drop down only shows myself (Org admin) and no other users. This is very frustrating as I've created a whole new account and project to try to overcome the issue only to find the same thing occurring. Any help would be much appreciated.

 

Update after more testing

The Assignee field is not working in the following ways

  1. All good if I Assign someone at the time of creation of a task
  2. If I (logged in a Org Admin) go to edit a saved task in the view/edit screen (from a Board or Calendar) the user list does not appear in the drop down - only the user who opened the task and the Org Admin appear. The original Assignee is there but I can't choose anyone else.
  3. If I go to the list view and try to change the Assignee in the list table (no pop up view/edit screen) I get a drop down list, but not everyone is on it. I can select someone from the list of viewable users. If I then go back to the Board view and open the task in the view/edit the new Assignee doesn't always display and I get "no option"

The instance I'm using is a brand new cloud instance without any other products running.

As I am using the free version I can not log bugs or issues. Can someone else log this for me?

This is a real show stopper for us running our pilot. We would like to roll this out to a wide audience but this type of "undocumented feature" really blows our confidence in the product and support service.

 

Work around

After much trial and error the problem can be worked around by starting to type the name of the user in the Assign field and they will appear and can be selected.

1 answer

1 accepted

0 votes
Answer accepted
Jack Brickey Community Leader Oct 20, 2021

This is likely due to other users not having permissions to browse or be assigned issues in the project. Is this a Company or Team managed project?

if CMP go to project settings > permissions and see if Browse, assignable user permissions are such that these other users have access. Users can be in roles or groups that are associated to permissions.

Thanks for the suggestion Jack. We are using the free version which has permissions locked so I can not change them, however it appears this isn't the issue as all logged in users have Assignable and Assign permissions and can see all issues as shown below...

Capture1.JPG

 

To provide some further clarification of the problem, once an issue (task) has been created and saved

  1. when logged in as an Org Admin I can only see myself in the Assignee list if I want to change the original Assignee. 
  2. when logged in a regular user I can only see myself and the original Org Admin in the Assignee list, not other users who have project and Org Admin permissions.
  3. if I give a user project and Org Admin permissions they can see themselves and myself as the original Org Admin only as in 2 above.

When originally creating the task the full list of users shows and I can Assign anyone. The problem occurs if I want to change the Assignee after originally saving the task.

Our typical workflow is that a task is created in the "Backlog" without being assigned. Then when it is ready to be done it is moved to "To do this week" (one week sprints) and allocated to a person. The problem is saved tasks can't be re-allocated. No problem if the person is allocated at the time of initial task creation, but not later.

We are piloting Work Management with a view to rolling it out to our division. Everything was fine with the setup and configuration when I was the only user however after adding more users and running into this basic problem is jeopardising the pilot. The product has the functionality we need, but this issue is a show-stopper for us. It would be a shame to not use the product because of this basic issue.

Jack Brickey Community Leader Oct 20, 2021

Oh wait it just occurred to me that with Free version all users are admins by default. Not sure how you added them not as admins. 

Hi Jack, it doesn't seem to matter what access users have, once a task is saved only the logged in user and the Org Admin show in the Assignee drop down.

What is puzzling is that the full list appears when first creating a task, but not when editing it.

Jack Brickey Community Leader Oct 20, 2021

it is puzzling as stated. i don't have a free version to test with unfortunately. i assume any new project behaves the same?

The same problem occurs for paid accounts as well. I'd be happy to hear the solution if any exists.

@Drew Cox thanks for mentioning the workaround!!

Jack Brickey Community Leader Jun 30, 2022

@chercher , I am not experiencing this. Please provide more details on your experience. You may wish to ope a new question as well to get more eyes on it.

Hi Jack and thanks for the quick response!

As we've found the work around thanks to @Drew Cox feedback, it's less critical for us now, hence there's no need from our side to start a new topic / ticket about this.

I thought mentioning this is still happening, and on paid accounts as well, for the Atlassian's benefit. Maybe you want to open a bug on this one.

Anyways, thanks for the help 😊
Mic.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events