Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

should operator '=' be supported by the 'sprint' field? Edited

in help docs, "=" is supported for the "sprint" field and yesterday my custom filter worked but today I'm getting the error message that The operator '=' is not supported by the 'sprint' field.

 

How should this query be re-written:

project = INTERNAL AND sprint = 1586 AND "Promoted to UAT[Checkboxes]" is EMPTY AND status = "Pass QA"

 

Here is the Jira help doc which leads me to believe that I shouldn't be having this issue:

https://support.atlassian.com/jira-service-management-cloud/docs/advanced-search-reference-jql-fields/

22809F9D-F149-4679-BE5F-C161D2437C35.png

2 answers

1 accepted

2 votes
Answer accepted

I figured it out ...I went to another list view of items that is provided by Jira OOTB and includes the Sprint column. I clicked on the Sprint column in order to ORDER BY that column to see what Jira would automatically add to the query bar. Apparently, I needed to use cf[10010] ...which I guess is some sort of alias for "sprint"

I am using JIRA Cloud also, and the "=" operator is still working for me with the sprint field in JQL searches.

Try simply re-typing that part of your filter. After entering "sprint" the intellisense for JQL should show you the supported operators.

Appreciate the response however, I've tried re-writing the query few times with no luck. It was working this morning and there had been no changes to the filter since.

Also, "sprint" is no longer an option to select in intellisense when I type the word "sprint" ...I'm not experiencing that with any other fields and "sprint is not a name which can be edited since it is a Jira-created field.

Is Sprint still showing up in your list of Custom Fields?

Also, is the JIRA Software product still enabled for your instance, and do you have access to it? The agile features, including the Sprint field, are part of JIRA Software. If that product is not enabled in your instance or you no longer have access to it, that could explain your inability to access the Sprint field. I would think that would also block your access to Agile boards.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Bitbucket Smart Commits vs. Genius Commits - What's the difference?

If you already heard about Smart Commits in Bitbucket, know that you just stumbled upon something even better (and smarter!): Genius Commits by Better DevOps Automation for Jira Data Center (+ Server...

106 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you