Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,687
Community Members
 
Community Events
168
Community Groups

"We couldn't save your comment"

Consistently over the last week, I've been having issues creating tickets or adding comments to tickets when screenshots are involved. Before this week, I could paste (from clipboard) a screenshot directly into the ticket body or a comment on the ticket with no issues. Now when I try I keep getting these warning messages saying that my entry couldn't be saved due to formatting. Has formatting changed that much? This is such a huge part of how we use JIRA with our teams - I need to be able to add these images and preferably without having to save them all to my computer to upload. 

Error message: 

We couldn't save your comment

It might be empty or have invalid formatting. If you copy-pasted, try removing formatting and adding it directly to the editor.

7 answers

1 accepted

0 votes
Answer accepted
John Funk Community Leader Dec 05, 2019

Hi Morgan - Welcome to the Atlassian Community!

I would open a support ticket with Atlassian - sounds like a bug may have developed. 

Thanks! Looks like I'll need to get my admin to reach out on this one.

John Funk Community Leader Dec 05, 2019

Let us know the result here so we can close this one out.  :-)

Morgan, I had this same issue and the problem was the name of the screenshot containing invalid characters. Just renamed to something like "test" and it works.

Regards.

Like # people like this

Thank you lourenco_raccoon this was really helpful. Was having the same issue and this worked. 

John Funk Community Leader Mar 24, 2020

Hi Omolara - I am glad Lourenco could help you out! Can you click on the Accept answer button above to close this one out? Thanks!

I can't see the 'accept answer` button

John Funk Community Leader Mar 24, 2020

No worries - I will hit it for you to close out.

Cheers!

Do I have to rename the images in order to post them in a comment? That's quite a nuisance. 

It turns out that you can only upload images or documents that are less than 10MB! It's unfortunate that the error is so vague but after I found that out I've had no further issues and have been using Google Drive for any videos I need to attach that are larger than that. 

Like John Funk likes this
John Funk Community Leader Jan 29, 2021

Another option is to do what we do and that is use a third party vendor called Simple Cloud Files. It is available in the Atlassian Marketplace. 

Tried renaming the file - didn't worked.

Changed the file size to less than 10MB - it worked !

I have same issue when I am trying to paste a video. I can see the video uploaded but when I push "Save" button I have: "It might be empty or have invalid formatting."

Fedora 36, Browser Chrome

[FIXED]  My problem was related to some characters in the filename. When the file was renamed the issue disappeared.

This issue was seen today solely because the videos included in the comment had / characters in the filename. As soon as I removed any / characters from the filenames and re-uploaded them into the comment, the comment saved as expected.

@John Funk - it would be sensible to have more specific error messaging here to avoid more people losing the time I lost trying to work out why the system wasn't working as expected. At the moment, the messaging does not direct users to check the filenames of attachments. Thanks.

--

We couldn't save your comment

It might be empty or have invalid formatting. If you copy-pasted, try removing formatting and adding it directly to the editor.

Thank you, renaming the file really worked for me.

0 votes

I have a issue when I am trying to paste a video (4.4 mb). I can see the video uploaded but when I push "Save" button I have: "It might be empty or have invalid formatting."

Screenshot from 2022-07-07 16-26-28.png

I am facing the same error when pasting in links containing / in the comments.

I faced this issue while attaching a video in '.mov' format. Converted it to '.mp4' and it worked.

I have the same problem, please help

Hey Donny, 

It turns out that you can only upload images or documents that are less than 10MB! It's unfortunate that the error is so vague but after I found that out I've had no further issues and have been using Google Drive for any videos I need to attach that are larger than that. 

 

Hope this helps.

Like John Funk likes this

What's weird is that not even Google Drive fixes it

 

If I upload a video to Drive that's more than 30MB, then try attaching it to the ticket using the Drive Integration, it's the SAME issue!

 

So my question is: how can I attach Google Drive videos greater than 30Mb to my tickets?

Screen Shot 2021-01-07 at 10.00.14 AM.png

Hmm - I haven't tried with the integration, I just add a link to the drive folder and have no issues that way

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events