Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"ISSUEPROP_async-game$playerNames" appears more than once in this document

/secure/admin/jira/IndexReIndex!reindex.jspa [c.a.jira.index.AccumulatingResultBuilder] Indexing failed for Issue - 'xxxx'

/secure/admin/jira/IndexReIndex!reindex.jspa [c.a.jira.index.AccumulatingResultBuilder] DocValuesField "ISSUEPROP_async-game$playerNames" appears more than once in this document

java.lang.IllegalArgumentException: DocValuesField "ISSUEPROP_async-game$playerNames" appears more than once in this document (only one value is allowed per field)

Planning Poker Version: 3.0.11-SNAPSHOT

Jira Software Version: 8.9.1

4 answers

0 votes

This is usually down to some code that does not write the right thing into the index when a field is updated.  A bug in other words.  It is also possible to get this broken index if

You may be able to fix it by running a re-index on the project(s) or whole system (background so people can carry on using it), but doing that at a time when you know no-one will be activly using Planning Poker.  That usually fixes it when the problem was created by a hard-shutdown, but probably won't help if it's a bug. 

I see you're getting the error from "reindex.jsp", so I am going to guess that you've already tried it, which would confirm that it is a bug

However, given the name of what it is has written to the index, I would say the bug is in the planning poker app, so you will want to raise it with the vendor of that.

I have the same issue

Ok, same answer as before.

Thanks. I know its a bug but the vendors response was "Install the latest and it should resolve the problem". 

 

I am running at the latest. So was wondering if anyone else solved this exact same problem excluding the canned answer from the vendor. 

@UNICEF Comité Español - Sistemas 

 

Ive been working with the vendor but figured Id at least share some of this. 

 

For Issue - xxxx

thats the issue ID that has bad formatting in it.  from the vendor a particular release or range of releases improperly stored the playerNames and playerAccountIds.

 

You can get the ISSUEKEY from your issue_id above

https://you-instance-url/rest/api/2/issue/<ISSUEXXXX>

the XML/JSON will tell you the ISSUEKEY in the results.

 

Assuming your running on linux and using postgres (which i am) do the following

ssh

su - postgres

psql -d <jiradb name>

a) 

SELECT * FROM ENTITY_PROPERTY WHERE PROPERTY_KEY = 'async-game'

b) If you have results then just rerun the below to export these results to CSV

COPY (SELECT * FROM ENTITY_PROPERTY WHERE PROPERTY_KEY = 'async-game') TO '<location>/filename' DELIMITER ',' CSV HEADER; 

 note: location is where postgres can write to, I just used the absolute path of the postgres user directory

scp that down to a machine that has excel to import the data and format so you can look at it. 

Its comma delimited so remember that. 

of note: you can also get this via a get request

curl --user <username> -X GET https://<jira url>/rest/api/2/issue/<ISSUEKEY>/properties/async-game

Same results look at  playerNames and playerAccountIds

 

Look in the entity_id column and find your issue, expand the json and look at the very end. 

In my case I had 

...,"playerNames":["Some User1","Some User2"],"playerAccountIds":["user1","user2"]}

Per the vendor its supposed to be 

["Some User1,Some User2"],"playerAccountIds":["user1,user2"]}

 

Now, we know what we need to fix, how to fix it well thats beyond me.  

 

In my case, the JSON for my bad ticket is huge. and it appears to not be formatted well. 

 

If the above all kind of matches your problem.  Ill post the fix once I have mine figured out.

sorry for all the edits, I kind of just realized the holes in what i was trying to say and fill in the gaps incase it left you in the dark.

update plugin to the latest version (3.0.13-SNAPSHOT) as it has few bug fixes and also an additional URL which helps to fix the “indexing error”.

After update, please watch this short video-helper how you can fix the problem 

https://www.screencast.com/t/F9r0kwmp 

What should be done:

  1. Get all needed rows from ENTITY_PROPERTY table, as we discussed in previous comments.
  2. Log in into Jira and in new tab enter next API URL like - http(s)://your_jira_server//rest/agile.estimation.3.0_private/1.0/game/fix-issues-indexing?issueIds=list_of_issue_ids where list_of_issue_ids a comma separated ENTITY_ID values from the table (please watch video-helper).
  3. Run prepared url in the opened new tab and check results in db.

After you run the API request all specified rows should be fixed and “indexing” should work again.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Jira

Announcing the waitlist for Jira Work Management

Hey there Cloud Community members! We’re excited to give you the first glimpse of the new home for business teams on Jira — Jira Work Management. Jira Work Management is the next generation of J...

880 views 14 20
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you