"Enable API Access" not visible in admin settings

Earlier I was able to select "Enable API Access" in the general configuration for our site administration. Now when I go back and try to find the setting it's not present. I have all the necessary admin privileges. Where the heck did it go?

2 answers

0 votes

Hi Charlie,

  • What version of JIRA are you currently using?
  • Did you upgrade recently?
  • When you say earlier you were able to Enable API Access when exactly do you mean?

It appears this was taken out of JIRA around 7.0 per JRASERVER-45768:

...this option is not available in JIRA 7 as JIRA's SOAP and XML-RPC remote APIs were removed in JIRA 7.0 for Server as per SOAP and XML-RPC API Deprecation Notice - Atlassian Developers.

If you are using an earlier version of JIRA let us know and we'll go from there.



I'm using Jira Cloud. This should be present, it's in all of their documentation plus I just enabled this about 2 weeks ago.

<ignore this 2nd reply>

Hi Charlie,

This is the Cloud bug JRACLOUD-45768 which states the same thing for Cloud.  With the way the development has been split for Cloud and Server it's possible that is still in/added back to Cloud for some reason, however, I'm unable to find that option in my 7.5 Server or my Cloud instance. 

If I use "g+g" the option comes up but it doesn't exist on the page I was redirected to:

Screen Shot 2017-10-09 at 1.01.41 PM.png

In addition, I checked with a Senior Cloud Engineer and the response was as follows:


The API in Cloud is permanently enabled and can't be toggled

This is also acknowledged by JRACLOUD-41876 - Adding a limit on REST API request:


Currently, there is no limit in sending REST API request. In some cases where users sending REST API request to run complex JQL queries with high frequency, it returns enormous number of results and it potentially causes an outage for the instance.

To prevent it to happen, it would be great if there is a limit on REST API requests.

I would check with the Cloud team if you can and see what could be going on with that instance because that shouldn't be a possibility at this point.  There are some add-ons that may need to have the API toggled so that may be a possibility as well.

If you feel comfortable providing your Cloud URL I can check to see what could possibly be going on.



The article you linked to refers to the SOAP and XML APIs, which make sense. 

I'm 99.9% confident this option still existed in my admin settings 2 weeks ago when I enabled it. But the documentation you pointed to says the REST API is permanently enabled, which makes sense. I'm just very confused b/c I'm having problems using it, and since I couldn't find the toggle again I thought something had changed or busted.

I'll see if the cause of my connection problem is something else. Thanks.

I have the same question. Can anyone answer please?

I am trying to connect using this SDK to my Jira cloud instance but it returns an empty result set. Since I had not connected to the API before, I do not know where the issue can be.

It's the same answer. 

The REST API is enabled and can't be disabled.  The other deprecated APIs are not there any more.

Your "empty result set" is down to the wrong query, not the API.  What are you sending over to Jira?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Feb 26, 2019 in Jira Software

How to prevent the propagation of unused project schemes, workflows & screens in Jira software

Atlassian ranks project attributes as the third most important factor impacting performance in the category of data. It’s not surprising, since project attributes are precisely the rules used to ma...

649 views 0 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you