{noformat} appearing in email from automation

Mike Surerus March 20, 2024

We just switched to Data Center, and I'm starting to explore the various automation features available to us. I've set up an automation to send an email that pulls data from the description field when a specific ticket comes in. I have everything working except for one part.

I'm using {{issue.description.substringAfter("Business Reason")}} that will pull any data someone entered from the field. The field "Business Reason" is the last field of the form, and there isn't anything in the description of the ticket after this. When the email is sent out, it provides the data given after Business Reason, but it's also putting {noformat} on the next line.

Here's the complete email I set up:

Ticket {{issue.key}} has been opened by {{issue.description.substringBetween("by ", ", please")}} requesting a new list {{issue.description.substringBetween("PUTALL ",".list")}} be created.

Their business reason for the list creation is:
{{issue.description.substringAfter("Business Reason")}}

You can view the request by clicking this link: {{issue.url}}

 

What is causing {noformat} to appear?

1 answer

0 votes
Kalyan Sattaluri
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 20, 2024

Hello @Mike Surerus 

Seems to be part of Wiki's formatting option.

https://jira.atlassian.com/secure/WikiRendererHelpAction.jspa?section=advanced

*guessing*

Maybe your users are right click-copying Business Reason from a confluence page which has this tag..  you dont see it in Jira because it handles wiki markup but emails show this?

Mike Surerus March 20, 2024

The form is submitted from an internal site on our network. It sends an email upon submission that triggers a ticket to be created with the contents of the form. I've submitted the form several times and manually typed info in the Business Reason field and it still had the {noformat} appear.

Suggest an answer

Log in or Sign up to answer