Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

XSRF Security Token Missing.

XSRF Security Token Missing.

Jira could not complete this action due to a missing form token

You may have cleared your browser cookies, which could have resulted in the expiry of your current form token.
A new form token has been reissued.

Request URL : /secure/WorkflowUIDispactcher.jspa

The original input has been captured and you can retry the operation.

23 answers

1 accepted

0 votes
Answer accepted

We started receiving this message today.  Did you figure-out a solution to the root cause?

Hi Maura Swart , I dont know the rootcause for this XSRF Token missing.

please help me with this.

regards

venkata Rajanna 

I was able to overcome this issue today by switching to the new issue view; however, our users prefer the old issue view so I don't think they are going to like this answer.

Like # people like this

How in gods name is this considered "Solved"?

Facing same issue since we updated jira to 8.5.3. Any resolution appreciated. Thanks in advance!

I am now hitting this "feature" in the Backup JIRA function. It starts the baclup and seems to finish it too, however, the GUI barfs and throws this XSRF token missing error, no matter if I'm at Edge or Firefox.
(JIRA 8.5.3)

/Sarcasm
Great work, Atlassian. I am now even more eager to be forced to pay DOUBLE for DataCenter license. You guys "rock" ..........
/Sarcasm

So I encountered this issue today when trying to clear the default value for Resolution field. The fix I have found for this is to go to the WEB-INF/classes directory and modify the value below from true to false in the jpm.xml file . You will have to restart jira for change to take effect.xsrf.jpg

Wow, this is the first fix I've seen posted in close to a year.  Thanks!  I'll have to try this out.  What version of JIRA are you running Lou?   

I am running 8.3.4. They mentioned changing the jira-config file but I don't even have that so it must be for older versions. 

Like SmartLynx Operations IT likes this

Not to be a party pooper but essentially you are cutting the tendons on the security provisions in the product to prevent it from throwing the error here. Cross site script detection is a necessity in today's world. Can we get a fix for this rather than just killing safety measures to prevent warning dialogs? 

Like # people like this

We have the same issue in 8.8.1

Is there a solution/fix for  this?

I also encounter this problem, but only when I change the status of a task whilst I am on the dashboard. It happens about 1 in 4 times. The error popup would appear with the question to retry. Retrying mostly works. So for me, it's only annoying. But strange none-the-less.

Why is this marked accepted? How did you resolve this issue? 

I was able to resolve this issue by removing extra fields out of the project. 

 

We had a single project imapcting the users of our instance with this issue, when reviewing the config i found that the project admin had added a large number of fields to the scheme resulting in this error. After removing unneeded fields from the project this issue went away.

Jira Cloud Admin

Like # people like this

Please define "large number of fields." 

I have only one user (that I know of) complaining about this error out of about 60 users, so I'm inclined to think it is their browser, or the fact that they need to toggle on and off VPN to access other services. 

We have a large service desk project that requires many custom fields, issue types, and request forms. It would be unacceptable to need to limit those.

We have about 15 of our users experiencing this issue.  It mostly happens when we are resolving an issue.  Retrying does work, but it's getting annoying.

We have cleared cache on all our browsers, but it hasn't resolved the issue.

Why is this happening?

Lazyness!

Like Ved Prakash Arya likes this

I'm facing the same issue with Jira Application (datacenter version) 8.14.1. It started when I added post function to create transition in a workflow.

Post function is "Email user(s) based on attribute in a selected Insight Object" set as shown below. Default assignee is Insight attribute type User.

Sends an email to users from the attribute Default assignee selected from the Insight custom field Used product or service. Sender email address is: foo@bar (default).

 

So basically it is set as described in here except there's no Condition.

https://confluence.atlassian.com/servicemanagementserver/post-functions-1044784443.html

 

If I remove that function Issues can be created to project just fine.

Hi folks, any permanent solution for this? I´m afraid, we´ve got a user that reported this kind of issue this morning. If it happens again, we will have a ticket to solve.

Regards.

I fixed this issue on two PCs.

Add your Jira site to the Allow list of "Cookies" settings in your browser (Edge/Chrome).

 

Edge: 

Settings -> Cookies and site permissions -> Manage and delete cookies and site data -> Allow -> Add -> {input your Jira site} -> Add

 

Chrome:

Settings -> Privacy and security -> Sites that can always use cookies -> Add -> {input your Jira site} -> Add

 

Good luck!

facing the same issue. 

May i know what's your solution for this issue ?

I am having the same problem as well. Despite using different browsers, incognito mode etc.   I encounter the same issues.  I have to keep trying multiple times  and 1 of 5 or 6  times it works temporarily and it went bad again. Is there a solution to this? First report is almost a year ago.

My fix.

1. Login as admin.

2. Click on top/right cogwheel and select System. Login again.

3. now you can use the Project menu.

Something is buggy !!

Like # people like this

Same problem here only for one of our users, he cannot modify the issue field on multiple projects.
I recognize the Atlassian laziness when they want to "solve" the problem quickly without doing anything , nice one guys ! 

Just had this error tonight - I'm one of our site admins

Trying to do a Bulk Edit on a Project to populate the Component field - and bam this error occurred

Frustrating to see it's an ongoing issue reported by multiple people with no solution provided

Same for me! Only getting this error in a specific project.

Other projects dont have this problem. Deleting all unnecessary custom fields does not resolve it!!

Please provide a fix / solution for this.

Hello,

After upgrade from Jira 8.2.2 to Jira 8.5.5, we have the same problem.

Still no real solution ?

Regards

Having the same problem. Retrying the action yields success, but having to deal with this dialogue frequently is unacceptable.

 

How is this being marked as "Solved"/"Accepted" when no real solution has been defined? Did someone need to get their ticket-queue down?

I started receiving this error today and I am the sole admin. It renders me unable to do any system updates/configuration changes to try to fix the issue. I tried upgrading to the latest version and it did not fix the issue. Switching to Firefox from Chrome seems to fix the issue. Clearing all the tokens only works until I have to log back in. I am unable to log in unless I check the token to remember my login. I am not in the Cloud, I am in a local install. I don't see a way to switch to a "new issue view". 

 

The error note "Please refer to this page for details on disabling form token checking." brings me to a broken link. 

any news?

Hello, same problem for me, after upgrade from Jira 7.9.13 to Jira 8.5.4

Still no solution ?

I've found this issue :

https://jira.atlassian.com/browse/JSWSERVER-20347

But no workaround for now...

There's an option in every user's profile to 'Clear All Tokens'.

Have you tried this?

Tried this solution, doesn't work !

Like # people like this

I've had this issue reported by one of our Jira users (out of about 80 total).   It seemed to occur when we upgraded to v8.4.2 in late October 2019.   Since it has only been once user its hasn't been a super urgent problem but I still want to get to the bottom of this problem. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

👋 Looking for 15-20 volunteers to test Atlassian training content

Hi everyone! Are you interested in beta testing Atlassian University’s newest (unreleased!) training course? We’re looking for 15-20 volunteers to test our newest training course, Basic reporting...

769 views 24 28
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you