Why doesn't webhook work with my url?

limborg November 25, 2019

Hello, I have an issue with sending request from jira webhook to endpoint of my app. App endpoint is not called.
I think that webhook is configured properly, but on the other hand I don't see any issue from app side. So I'm confused and need a help.
My webhook is triggered as post function and was added as last step to transition. I've tried to put url from a pipedream service to test post request from webhook and it works correctly. I received request with two query parameters: user_id and user_key. 
As you can see below I've also tested my endpoint via postman and it works. 
What the problem could be?

Pipedream url:
test_jiralink (2).PNGjiralink_request.PNG

My url:
domain_jiralink (2).PNG


5 answers

2 votes
Kirti Jain October 27, 2020

I also am facing the same issue. Any suggestions what am I missing?

0 votes
KL Foong March 31, 2024


For Jira Cloud, WebHooks post function only works intermittently at the moment due to this bug WebHooks not firing when the event triggered is Workflow post function  

Can try Automation rule to send web request triggered by Issue Transitioned

For Jira DC, enable SSL debug logging to check if it fails due to SSL error. For SSL error, external server SSL certificate will need to be imported into JVM that runs Jira DC.

0 votes
Dev Bonebone March 30, 2024

im also facing the same issue, does anyone know how to solve this?

0 votes
Rod November 16, 2020

I am having this same issue. If I use the Requestbin URL, it works, but when I use my application url it does not reach it.  If I use curl from the JIRA server to send to my application end point the same data payload it works, so I know it is not an issue between the JIRA server and the application end point...

Below is the requestBin result and below that is the configuration of the webhook.  If I simply change the URL on the webhook, in the JIRA traces I see no difference except I do not receive the "WebHook successfully sent" message after the "Posting to web hook at 'https://myurl/functions/JIRAWorklogWebHooks?user_id=rpeck&user_key=rpeck'" that I do receive when using the url for RequestBin...requestbin-result.pngrequestbin-works.png

Rod November 16, 2020

For my case, it looks like it was related to my ssl certificate chain, and in fact it was reaching my application server, but the connection was being aborted... I can't explain why the curl approach worked and the webhook from JIRA failed, but when I tried through a different certificate it worked.

0 votes
Aman Kumar October 27, 2020

Same issue, pls help.

Suggest an answer

Log in or Sign up to answer