Why Sprints are not shown in the Plan (timeline) for Advanced Roadmaps (Jira Premium)?

Mauricio Neves August 11, 2020

Hello,

 

While watching the tutorial for Advanced Roadmaps, the timeline / plan was aggregated on a Sprint Level, along with the dates. See Image 1. But when trying it out, it is not possible to show the Sprints in the plan, only as a column / field. See Image 2.

I am using Jira Cloud. Maybe this is not available for cloud, only for server?

 

Image 1

Image 1.PNG

 

Image 2Image 2.PNG

Thank you in advance,
Best,
Mauricio

4 answers

1 accepted

1 vote
Answer accepted
Jira Guru
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
August 11, 2020

Showing capacity in the timeline

  1. In the roadmap view of the plan, click View settings.
  2. From the 'Group by' menu, choose Team or Sprint.
  3. Select the Show capacity on timeline checkbox. This will display the sprints and iterations associated to the teams in the plan in individual swimlanes.

Check this link for additional information:

https://confluence.atlassian.com/advancedroadmapscloud/displaying-capacity-in-a-plan-998651204.html

Mauricio Neves August 13, 2020

Thank you very much! It works - simple detail that has been overseen!

Best

Mauricio

Dave F January 20, 2022

This needs a step 4 as @ronald.miranda points out below. 

4. Assign a row item to a team

It seems that even after configuring the Plan with boards that have sprints, the sprints from the board do not appear until you assign a team to a task in the Plan view. 

Like # people like this
Smita May 10, 2023

Thank you Dave, this is missing from Atlassian documentation as well. I was struggling with the view for sometime but your answer solved my issues.

Like Joe Pursel likes this
1 vote
Alex Shabetayev March 16, 2023

I found the fix through this: https://support.atlassian.com/jira-software-cloud/docs/what-are-external-sprints-in-advanced-roadmaps/

Basically, you need to source the plan from a board that has the sprint in, usually a scrum type board.

1 vote
Dave F August 15, 2021

I'm having a similar problem - no sprints shown in the timeline, and that feature would be very useful to us.

I have selected to group by Sprints, enabled Show capacity on timeline, and am using the Sprint Capacity view. AS you can see in the screenshots though, no sprints on the timeline.

Reading through the linked KB pages suggested above did not provide the fix. Please suggest my next steps?  Thanks

Screenshot 2021-08-16 153807.png

Screenshot 2021-08-16 153900.png

Screenshot 2021-08-16 154043.png

Ricardo Ardito August 24, 2021

Exactly same problem here!

Dave F August 25, 2021

Navigate to Plans > my view > dropdown off view type > Manage views > Issue sources.

Set the issue source to use the Scrum board where you have created the sprints you wish to see because sprints belong to Scrum boards, not Projects.

I've not tried adding multiple sources so I can't comment on what would happen if you do.

The UI for Plans is not what I would call intuitive or simple and is very easy to configure incorrectly, which is a shame. 

Support doco here for those needing help, for what it's worth - https://support.atlassian.com/jira-software-cloud/docs/create-a-plan-in-advanced-roadmaps/

Like # people like this
Chris Deutschmann September 3, 2021

I have same issue and @Dave F  your suggestion didn't work unfortunately.

Any other ideas?

Dave F September 5, 2021

Sadly, no. I've since broken my view while experimenting with how Teams will work with our planning and can't work out how to fix it. As I mentioned, Plans is very easy to configure incorrectly, which is a shame. It really feels like you have to get planets and their moons to align - anything other than the prescribed method and you don't see all the useful features.

ronald.miranda January 20, 2022

I could make it work by creating a Team in the plan, then you should create your stories under this team and you will see the sprints in the timeline, 

Like Dave F likes this
Dave F January 20, 2022

@ronald.miranda has found the trick. It seems that even after configuring the Plan with boards that have sprints, the sprints from the board do not appear until you assign a team to a task on that board. 

Kenneth Woo December 7, 2023

I just want to see sprints on the timeline when I select Group By: Project. Then it will be very useful. Why Group By: Team to display sprints only? I don't understand.

Like # people like this
0 votes
Jane Zhitnitsky March 11, 2024

You also need to ensure that the right source (board) is set for your Team. This could be done under Team settings.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
AUG Leaders

Atlassian Community Events