Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

What causes Commitment to be zero on my Velocity Chart?

What causes Commitment to be zero on my Velocity Chart?

I believe all Stories had Story Point values before Starting the Sprint. Also, my first sprint had a value in Commitment. I don't know what I did differently.

My Board is configured to use Points for Estimation Statistic and Remaining Estimate and Time Spent for Time Tracking.

7 answers

1 accepted

9 votes
Answer accepted

That did the trick; I got Commintment back. My lesson, sprint start time, after done planning sprint (seems obvious after the fact).

I have the same problem, what did you do to get the commitment back for that sprint?

Cheers.

Like Agnes Varga likes this

I don't believe I was able to change previously completed sprints, but for all subsequent, I made sure my sprint start date and time was before any work (status change or hours logged) was done on sprint items.

Similarly when completing the sprint, make sure end date and time are after everything for the sprint has been updated in Jira.

Hope that helps.

I really could not understand - what to do you mean here in your answer, I think, what Paul Greg mentions is correct (below).

Like # people like this
7 votes
Paul Greig Atlassian Team Aug 29, 2013

Hi Benjamin,

Just wanted to help you out on this issue :) It sounds like you have added issues to your sprint after the sprint has begun. As discussed in https://confluence.atlassian.com/display/AGILE/Viewing+the+Velocity+Chart the 'Commitment' value is calculated on the issues and stories added before the start of the sprint.

A quick way to find issues or stories that were added after the sprint start is to view the Sprint Report. Issues that have a star next to the key were added after the beginning of the sprint.

To resolve the issue in future sprints you would create the sprint, add the issues from your backlog and then begin the sprint.

Cheers,

Paul

I had the same problem and here's how I solved it for a past sprint:

 

1) From the velocity report, go to the sprint in question from the list below the visual chart.

2) Reopen the sprint, from the options in the '...' menu on the right

3) Go to the backlog and edit the start time of this sprint to later than when the stories with asterisks* were added.

4) Close the sprint again.

 

Now the commitment will include all the stories with a time stamp before the start time you entered. 

Perfect - thanks. That sorted it for me.

Like Ali Sohail likes this

hello Ali & all,

when i tried to use that method, i met one issue, i can see commitment from 0 -> right number, but completed from right number -> 0? any idea? 

thanks,

Eugene

That's strange.

I just made sure all the items were part of the re-opened sprint (with starting time adjusted) at the point when I closed it again and it worked.

 

May be try it again, making sure the individual tickets are actually 'done,' as per their workflows...

yes. i have tried several times, no effect for me. 

This response was EXACTLY what I was looking for. Thanks @Ali Sohail for the good information and direction on how to do this. Saved my bacon, because I had forgotten to close out 7 tasks that were sitting in testing and "technically" complete!

Hi Ali,

I had the same problem and it is solved with your help, thanks. But, I want to remind to you that with reopening sprint, burndown chart end date changes and this also leads to distortion of the chart. 

Like Kevin Morton likes this

Hi, 

 

I have also just tried this and it did not work for me. When reaching out to Atlassian Support, I was informed that this is not a viable workaround. They have, however, raised a feature request for this so I suggest we get some more votes on it here: https://jira.atlassian.com/browse/JSWSERVER-20136

 

Another proposed, but not necessarily recommended workaround, was modifying the history entry of the entry when the issue was added to Sprint - that would need to be changed in the database though and can potentially cause data integrity issue. 

 

Hope this helps!

We're using a new world project and those options don't appear to be available (to re-open, edit the start date and close a sprint). ☹️

0 votes
AhmadDanial Atlassian Team Aug 26, 2013

Hey there, Benjamin.

Could there be an inconsistency in your JIRA instance that causes the values not being displayed properly? Have you tried to perform reindexing (https://confluence.atlassian.com/display/JIRA/Re-Indexing+after+Major+Configuration+Changes) to see if you still have the same issue? I am suspecting this since you mentioned that yor first sprint didn't suffer from this problem.

Warm regards,

Danial

Thank you Danial! I will reach out to our admin and find out.

Ben

Our Jira admin just completed the reindexing and unfortunately the issue still exists (verlocity chart is still showing zero for commitment on last two sprints)

Try configuring your Estimate to use the Commitment field instead of Story Points

Thank you Matt. I checked the Estimation options and Commitment is not one of the available options.

My Administrator submitted the question to Atlassian Tech Support and I believe the root cause is self-inflicted (I will confirm when completing my active Sprint Friday).

During Sprint Planning, we added Stories to the Sprint, with Story Points and then I Started the Sprint. However, after hitting Start Sprint, I changed the Start Time to the beginning of the day. Since the Stories had a later timestamp, they were consider added after the Start and thus not part of the Sprint Commitment.

Changing the Start Time of my Active Sprint (to after Sprint Planning completed) has already cleaned up my Burndown chart, so I'm hoping my Commitment value will be non-zero. If so, I will keep the default Start Time (current time) when Starting future Sprints.

It's been months since the thread started, but I'm in the same situation.

So , no changes to the past sprint possible, ie, the velocity chart is screwed up for ever as far as tracking goes?

Even though our sprints begins after we complete the sprint planning currently I have the project showing only commitment in the first sprint in the Velocity Chart, I have two additional sprint without commitment, any updates and/or hit to be able to register the sprint commitments?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,664 views 22 33
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you