Users not appearing when creating automation rules

Paul Ricco March 19, 2024

We're testing out JIRA Cloud, and I'm looking at creating a rule for adding watchers to certain issues types. The problem I'm having is that when I start typing in user's names into the "Add these watchers" field nobody is showing up for selection.


I'm able to type people's names into the user fields for issues such as Assignee, and the Watchers and see users listed. Is there a different permission required for when we're creating automation rules?

2 answers

1 accepted

1 vote
Answer accepted
Nicolas Rigaill March 19, 2024


Do you have the "browse users and groups" global permission ? 


Paul Ricco March 19, 2024

I think this might be the issue, I thought the existing permissions would be present in our test instance, but this appears not to be the case. We're just making the change now, if that turns out to fix the problem I'll mark this as fixed with this reply as the answer.

Paul Ricco March 22, 2024

This did turn out to be the problem, thanks for your help.

0 votes
Trudy Claspill
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 19, 2024

Hello @Paul Ricco 

Welcome to the Atlassian community.

Do you get the pop-up at all that would start to show matches? In this example there are no matches.

Screenshot 2024-03-19 at 9.57.03 AM.png


Have you tried another browser application? Have you tried a private browser window, like Chrome Incognito?

Do other users creating rules have the same experience?

Paul Ricco March 19, 2024

Hi Trudy,

We're in the first stage of our tests for the cloud instance, so I'm pretty much one of the few people trying things out at the moment. This pop-up doesn't appear when I start typing, I suspect the issue as @Nicolas Rigaill has already pointed out.

Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events